In the past Python 2.6 was included with OS X 10.8.

What version or versions come with 10.9 Mavericks?

up vote 10 down vote accepted

It's on 2.7.5.

Python 2.7.5 (default, Aug 25 2013, 00:04:04) 
[GCC 4.2.1 Compatible Apple LLVM 5.0 (clang-500.0.68)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> 

My MBA, which has been incrementally upgraded from 10.7, contains the following versions of Python:

Python 2.5.6 (r256:Unversioned directory, Aug 25 2013, 00:03:43)
Python 2.6.8 (unknown, Aug 25 2013, 00:04:29)
Python 2.7.5 (default, Aug 25 2013, 00:04:04)

Being that they have the same build date it would appear that all versions of Python have been updated with Mavericks.

Python 3 is not installed on my machine.

  • Great. Thanks for the extra detail. – beroe Oct 23 '13 at 14:28

On my rMBP, my upgrade from 10.8.x to 10.9 lists the following versions of Python in /System/Library/Frameworks/Python.framework/Versions:

2.3, 2.5, 2.6, and 2.7.

There is no Python 3.0 listed here for me. One can use MacPorts (and probably Fink or homebrew) to get Python 3.

  • Thanks. So it sounds like it might depend on the upgrade path? (BTW avoid macports for Python installs. Nightmare.) – beroe Oct 23 '13 at 14:38
  • Hodgkin-huxley Did you install 2.3 yourself? That hasn't shipped from Apple since Tiger (10.4). – Mark Oct 23 '13 at 14:49
  • 2
    I did not, isn't that bizarre? Also, I wholeheartedly disagree to avoid MacPorts for python. It's sandboxed (/opt/) and plays nicely with other python things in MacPorts. In my opinion THE best way to get a custom worthwhile install of python, numpy, scipy, matplotlib, etc. – hodgkin-huxley Oct 23 '13 at 15:58
  • 2
    Re MacPorts, not to extend a side debate, but if you have normal non-MacPorts Python already and want to install a library, in my experience it will spend 4 hours installing its own version of Python and create a lot of headaches. For someone starting out who hadn't used MacPorts for their Python install, I would strongly recommend pip or easy_install for matplotlib, etc. – beroe Oct 23 '13 at 18:09
  • If all easy_installs went as planned, I'd tend to agree, but IME, extending python with specific modules, etc. almost never plays nicely with Apple's python install. And that's one that seems particularly fragile, too. Better to sandbox if (and when) things go wrong. – hodgkin-huxley Oct 24 '13 at 14:19

On July 2017 on Sierra 10.12.5, I have versions 2.7.10 and 2.6.9.

The 2.6 version is also pretending to be 2.5 and 2.3

$ ls -l /System/Library/Frameworks/Python.framework/Versions
2.3 -> 2.6
2.5 -> 2.6
2.6
2.7
Current -> 2.7
$ /System/Library/Frameworks/Python.framework/Versions/2.7/bin/python --version
Python 2.7.10
$ /System/Library/Frameworks/Python.framework/Versions/2.6/bin/python --version
Python 2.6.9
$ sw_vers
ProductName:    Mac OS X
ProductVersion: 10.12.5
BuildVersion:   16F73

MacBook Pro, 13-inch, 2016, non-touchbar.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.