3

According to the Gmail web interface, I have 319 messages in my inbox, 51 of them unread.

According to Apple Mail earlier this afternoon, back when I was running Mountain Lion, the same was true.

I upgraded to Mavericks. Now I have 8 messages in my inbox. As far as I can tell, the missing messages do appear in the new "Archive" folder, but mixed in with all the other messages I've archived over the years.

Does anyone know what causes this and what can be done about it (besides restoring to my backup of Mountain Lion?

  • Once the count went to 8 - do the web interface and the native mail app both agree on mail counts and contents? If so, you might not have good luck restoring things from your backup as I don't know how to convince gmail your store (a cache of the cloud version) is authoritative. – bmike Oct 23 '13 at 0:34
  • Nope. Web interface still says 319. – Daniel Oct 23 '13 at 0:40
  • @DanielLawson This article may also be of interest macobserver.com/tmo/article/… – Simon Oct 26 '13 at 10:24
1

I can confirm what Bob posted: open your GoogleMail or GoogleApps e-mail inbox directly in a browser and mark them all as "unread". Then sync your e-mails in Apple Mail by clicking "Send & Receive All" (or whatever it's called in the English Apple Mail user interface). Then, in your GoogleMail, mark them all as "read" and sync again.

That's it, the e-mails will show up correctly.

  • This was detrimental for me - I now have duplicates. – andrewb Dec 8 '13 at 22:25
  • This is strange, it worked perfectly fine for me. Does removing/re-adding the e-mail accounts help? – Rias A. Sherzad Dec 10 '13 at 8:23
  • I did sort of try re-adding. I just don't have time to stuff around with it anymore - as my Mac is the only thing that has trouble syncing, if I just do all my IMAP stuff on that (sorting folders etc.), then it works out ok. – andrewb Dec 10 '13 at 21:40
2

I had zero messages in my mac mail inbox but 33 in my gmail inbox. I marked the messages as unread in gmail and they all appeared in my mac mail. I then marked them unread.

  • Should the last word in your answer be "read" or "unread"? – beroe Oct 23 '13 at 14:31
2

A Mail update for Mavericks is now available.

Mail Update for Mavericks includes improvements to general stability and compatibility with Gmail, including the following:

  • Fixes an issue that prevents deleting, moving, and archiving messages for users with custom Gmail settings
  • Addresses an issue that may cause unread counts to be inaccurate
  • Includes additional fixes that improve the compatibility and stability of Mail

Download here

1

This is an answer but not an explanation. When I disabled 2-factor authentication on my Google account, all my messages appeared. I don't have any explanation why I was able to download 8 (new!) messages but not the others — if the computer couldn't authenticate, it would seem that none of them should show up. But that worked. Now for the why…

  • Interesting. I just saw similar behavior when I sent an email - all other messages disappeared except for that one. When I clicked to the Archives, and then back, they showed back up. Have you re-enabled 2-factor auth to see if it will create the problem again? I have 2-step auth on two of my Gmail accounts, and again, they are working at the moment. – bassplayer7 Oct 23 '13 at 2:03
0

I've just tried a lot of things, for now the best method seems to be only using my Mac for IMAP actions. If I do them on anything else, my Mac is inconsistent about updating it, which isn't exactly acceptable.

0

For those struggling with this, two things: #1. There's an update for OSX today which supposedly deals with mail. It didn't solve the problem for me, but it's worth updating anyway. And #2. Logging into my Google Settings security page (not to be confused with Gmail settings) DID SOLVE this issue for me, though I have absolutely no idea why. Following a suggestion on this page, I logged into Gmail to check to see if I'd enabled 2-step authentication. I had NOT, which means I didn't change it... but when I clicked back over to Apple's Mail app, suddenly, all of my messages were there even though I did nothing other than log into my Google settings page to check my settings (but, again, I did not change them).

So, for me, this issue was solved (temporarily?) by simply logging into my Google settings security page. YMMV, but definitely be sure to log into your Google Settings.

I should note that I'd given up on Mail since upgrading to Mavericks once I realized messages weren't being delivered. I switched to the Airmail app (it's ok). Interestingly, Airmail seem to receive all messages, including the ones that Apple's Mail did not.

0

Here are the steps to get back deleted GMail on Mavericks.

  1. When you open mail, you’ll see the sidebar where the folders were before.
  2. You’ll see these options: MAILBOXES, ON MY MAC, SMARTMAILBOXES
  3. Hover your mouse over “ON MY MAC” and then click “Show”. The folders should be back.

Content from- http://www.askiyogi.com/gadget/40845.html

Hope it helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .