1

I'm having 4 problems with O365 and Mac OS X Email, all related to display and status issues. To be clear, I'm using the built-in Mac Mail client, connecting to Office 365 as an Exchange server (vs. not using Microsoft Office email, nor O365 web interface) It's generally working, I get my company calendar events and contacts as well as email. The first 3 problems are fixed if I exit Mail and restart (not sure about the 4th)

Problem 1: (most serious) Sometimes a reply to a thread appears suddenly appears above that thread's header. If I restart, the message is properly shown under the thread header. This happens at least once a day. If this is the top thread in my inbox, the email is still indented, but way at the top, not under any thread heading.

Today I saw a really weird variant of this. The email reply moved from it's proper thread so that it appeared to be part of the thread above, but still properly sorted by date/time within that other thread. Exiting and restarting moved it back to the proper thread.

Problem 2: In the message viewer window, sometimes the To field improperly displayed, with superimposed text. I think it's the person's name and email address, but hard to read. If I restart email, the message displays fine.

Problem 3: Sometimes the content of a message is not visible in the message viewer window, and appears blank. If I restart, the message is visible.

Problem 4: (minor) Sometimes the read status doesn't clear once I've read a message. If I right click in the inbox and specifically change the status to Read, the indicator goes away.

I realize there a chance for finger pointing here, Apple fans saying it's Microsoft's fault vs. Microsoft fans says it's Apple's fault. But I decided to post to the Apple community, in part because I think there's maybe a better chance of getting an answer, and also because when I restart Mac Mail the problems go away. (that doesn't make it Apple's "fault", but makes it a very localized symptom). Also, I haven't heard any of my coworkers complain (using various OS X, iOS, Windows, Android phones, etc)

Of all the issues, item 2 seems the hardest to blame on Microsoft. The data is clearly there, it's being displayed, just incorrectly.

Any advice would be helpful. I'm getting to the point, some days, I have to restart email every couple of minutes. Other times I can go days without seeing these problems.

This is was originally on OS X 10.8.3 Mountain Lion, although still an issue with 10.8.5

I originally posted this back in May at Apple on https://discussions.apple.com/thread/5038346 but I didn't get a solution and some days the problem is really bad. Sometimes I have to exit and restart email every couple of minutes for a spell.

  • Updated to Mavericks yesterday. Still having the problem where it sometimes doesn't pickup new email or mark things as read unless I restart; the not getting new email is a bigger issue of course. Haven't seen the other issues BUT that's pretty inconsistent, so not sure it's changed or not. – Mark Bennett Oct 23 '13 at 19:46
  • Updated to latest OS X release, which specifically included Email / Mail app updates (approx Nov 13, 2013), but same problems. To be fair, the app store description said the mail updates were for Gmail issues I think, nothing about O365. – Mark Bennett Nov 14 '13 at 20:30
  • did you look in the Console to see if there is anything reported? – Ruskes Jun 6 '14 at 8:35
  • @Buscar웃 that's an interesting idea, I fired it up, I'll look today. During the WWDC keynote last week they said the email in Yosemite would also focus on getting the "basic things right", so I'm hoping that might address this. Of course I hoped that with Mavericks to and didn't help. – Mark Bennett Jun 9 '14 at 17:06

You must log in to answer this question.

Browse other questions tagged .