1

How the problem came to be:

  1. I wanted to dual boot Debian on my MacBook Pro 8,1. I got my USB ready, downloaded ISO, and installed rEFInd. I restarted to make sure the new boot manager worked. It did.
  2. To burn the ISO on my USB, I followed the instructions on the official Debian page, which require the dd command.
  3. However I was careless in my typing, and instead of choosing my USB to load the iso to, I chose a 10GB partition that I had set up long ago (i.e. of=/path/to/10GBPartition instead of of=/path/to/USB ). Tragically, I restarted my computer right as I realized what I had done.

Now, my computer loads immediately into a gray screen, and stays there. The screen comes up just about a second after the boot chime sound. I tried SHIFT, ALT, SHIFT+CMD+V, and I even tried inserting my OS X Lion CD, but absolutely nothing works. It simply goes straight to a gray screen, with nothing on. Any ideas on how to salvage this system?

Thanks for any and all help.

1

You could also try holding command-R to start up in recovery mode, option-command-R to start up in Internet recovery mode, or command-S to start up in Internet recovery mode. Or try using Recovery Disk Assistant to create a recovery partition on an external disk.

If you can somehow start up from the recovery system, one thing you can try is to choose the Reinstall OS X option. It downloads and installs a new copy of OS X over your existing installation and keeps user files and settings in place. It fixed a problem I had where my Mac got stuck during the startup process. (I don't remember what part it was though, and I was able to start up in single user mode and from the recovery partition.)

If nothing else works, you could try replacing the hard drive with an empty drive. Since your Mac has firmware support for Internet recovery mode, it would normally start downloading a disk image for the recovery system from Apple's servers, and then allow you to install a new copy of OS X on the empty drive.

1

I am lucky enough to have family with plenty of Macs nearby my place. As a consequence, in this kind of situations, I don’t hesitate to use the good old Target Mode.

Boot while pressing T; the Mac boot as an external disk, which you can connect to via FireWire or Thunderbolt (depending on your model of Mac). This is incredibly useful to get data back from a non-booting computer, or to try and fix a hard drive, or even to install a system on a machine with a non-formated drive and no installation DVD or USB drive.

0

I've done the same. Intentionally. It seemed like a good idea at the time.

In the end, I had to remove the drive and clear the partition. Having a CD filesystem where it doesn't belong seems to really, really hurt their EFI implementation. Anything that requires EFI to scan to see what partitions are available, will hang.

  • Thanks. This seems like the only solution available, unfortunately. Now, just to make sure: how did you go about clearing that partition? – shblsh Oct 22 '13 at 17:02
  • The same way I (and you) broke it, but using /dev/zero as the source (if). But please, please, please double-check which partition you're writing to this time! – Shaun Oct 23 '13 at 22:45
  • So do I have to remove it from my laptop and open it as an external hard drive? – shblsh Oct 26 '13 at 20:29
0

I have just had a very similar problem: I had a Mac Mini on which there was nothing but Debian installed; my boss wanted a dual booting MacOS/Debian. With recent experiences in dual shrinking MacOS-partitions I thought it might be a good idea to set up partitions first, then reinstall MacOS.

Everything went fine until I finished the debian installation and rebooted into grey nothingness.

I tried every keyboard shortcut I could find, including resetting the PVRAM - which actually worked and caused me to have to deal with the startup sound again (which I turned off in MacOS before) - but none of them did do anything. I could not boot from cd/usb/internet, into verbose, safe, mode...

I then decided to remove the disc from the machine and to analyze it on another machine. The steps in https://www.ifixit.com/Guide/Mac+Mini+Late+2012+Speaker+Replacement/11727 helped. I only followed these instructions until no. 12, then I could remove the hard disk drive.

I plugged in the machine and found the following: Debian had somehow managed to initialize my /boot partition twice:

root@delta:~# wipefs /dev/sdc4
offset               type
----------------------------------------------------------------
0x3                  exfat   [filesystem]
                     UUID:  5441-1031

0x438                ext2   [filesystem]
                     UUID:  ea926f51-8909-4adf-af05-46870faf36a1

With this fixed (wipefs /dev/sdc4 -o 0x3) everything worked immediately.

It might be too late for your machine, but perhaps not too late for others.

And one thing to mention: if you want to remove your speaker in your Mac Mini the instructions on ifixit.com state something about the Mac Mini Logic Board Removal Tool, which is available for $4.95 as a remake and for $39.95 as original apple-designed. I used a paper clip. Save money. Be good.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .