I need to install XQuartz in Mac 10.8.5.But every time when I reach the destination folder selection in installation step,it freezes and doesn't move forward.I have admin account as well but as I looked through the net, seems that others also have the problem.How can I solve it?

4 Answers 4


You may be able to install the software using installer on the command line. You will need to make sure that you have the XQuartz disk image mounted before performing this command:

sudo installer -pkg /Volumes/XQuartz-2.7.4/XQuartz.pkg -target /


Apparently, the XQuartz installer is not allowing installation on the boot drive because it is failing some pre-installation checks. This is based on the following error message that occurred when attempting to use installer in Terminal:

installer: Cannot install on volume / because it is disabled.
 installer: This update requires you to first update your system to OS-X 10.6.3

The installer is not recognizing the system as the correct version. Although the contents of /System/Library/CoreServices/SystemVersion.plist shows that the value of ProductVersion is set to '10.8.5', the installer does not see it this way.

It may be possible to modify the package's Distribution file to allow it to install correctly:

  1. Mount the XQuartz-2.7.4.dmg disk image (assuming that it's on the Desktop):

    hdiutil mount ~/Desktop/XQuartz-2.7.4.dmg

  2. Expand the package into a folder name XQuartz on the Desktop:

    sudo pkgutil --expand /Volumes/XQuartz-2.7.4/XQuartz.pkg ~/Desktop/XQuartz

  3. Modify the Distribution file inside of the expanded package, to allow installation to occur (regardless of the system version):

    cat ~/Desktop/XQuartz/Distribution | sed s/false/true/g > ~/Desktop/Distribution

  4. Move the new Distribution file into the expanded package

    sudo mv ~/Desktop/Distribution ~/Desktop/XQuartz

  5. Flatten the modified package:

    sudo pkgutil --flatten ~/Desktop/XQuartz ~/Desktop/XQuartz.pkg

  6. Cleanup the XQuartz folder that was expanded from the original package

    sudo rm -rf ~/Desktop/XQuartz

After creating the modified package on the Desktop, you may be able to double-click on the file to get it to install normally. Alternately, installing using the Terminal may also work at this point.

  • I doesn't work.Do I need to change anything in the command?? target or something?it says it is invalid
    – Alex
    Commented Oct 24, 2013 at 18:15
  • What exactly does it say is invalid? Commented Oct 24, 2013 at 20:29
  • It just freezes.It doesn't go forward.I can go backward but not forward.By the way I even tried to install it in root user but same problem happened
    – Alex
    Commented Oct 24, 2013 at 21:50
  • @Alex I've added additional suggestions to the answer above. Commented Oct 25, 2013 at 18:10
  • Hi,As I wrote my opinion for other question. In wont work.I think it is a problem of the company Application Provider trying to push apple to include Xquartz in Mac OS 10.8.5 application!!!How is your idea?Look at here (discussions.apple.com/thread/5418622
    – Alex
    Commented Oct 25, 2013 at 18:26

Many thanks for the people who provided the answer for this question.But the answer was kind of easy .That was a bug in the Mac OS 10.8.5 .I upgraded the system to OS X 10.9 and now it works perfectly!!!Many thanks for the contributions.!!!


Since in your comments you say you can go back, but not move forward the installer hasn't really "frozen" so perhaps the following is the rather simple solution to your problem...

I have just successfully reinstalled XQuartz 2.7.4 on Mavericks and at the Select a Destination screen the Continue button was disabled. I had to wait a second or two and then had to select the Install for all users of this computer line even though it appeared to be already highlighted before I could continue.

  • Hi I waited around 10 min but nothing happened DD.Thats means with only patient it is not going to get fixed;). I can not select instal for all users of this computer
    – Alex
    Commented Oct 25, 2013 at 15:33

I downloaded it from CNet and was able to install it without any hickup

  • Hi link doesn't work
    – Alex
    Commented Oct 24, 2013 at 7:07
  • @Alex Try this link: download.cnet.com/XQuartz-X11/… or search directly in CNet
    – Barranka
    Commented Oct 24, 2013 at 15:23
  • sorry same problem!
    – Alex
    Commented Oct 24, 2013 at 16:27
  • Then google this: CNet XQuartz (don't know why it doesn't work... I've used the link on three different computers and it works just fine)
    – Barranka
    Commented Oct 24, 2013 at 16:42
  • I mean the same problem is in installation not finding Xquartz. Yes this is also new to me.Did you see the link about same question that I had in my question text?
    – Alex
    Commented Oct 24, 2013 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .