0

I have an almost new Macbook Air. I started to use Time Machine for the first time with a brand new "My Passport" hard drive. I had to unplug it during the process and it was left unplugged for quite some time. Then it went to sleep probably or maybe not, but I plugged it. Then unplugged again (one charger was shared between two Macs).

Cannot turn it on now! The light on the plug cord is green as it is fully charged. I changed the socket just in case. I tried with USB My Passport drive plugged in and not. Nothing happens.

1
  • 2
    Take it to the shop. It is still covered by the warranty unless you did something silly to void it. – M_dk Oct 21 '13 at 2:39
4

Keep pressing your power on button for 5 seconds.
The press it again for normal power-up.

You could also try this: Apple Support Page

1
  • Thanks, worked. Though, I tried that before, just did not press and hold long enough. So, first Time Machine backup should go without interruption. I had an option checked when backup gets interrupted on power supply disconnected. Corrupted backup recovery is a long process. – mel Oct 21 '13 at 16:43
-3

Try this article very clearly Explain might help someone with mac issues

http://itrepairguide.com/apple-macbook-pro-not-power-on-no-sign-of-life/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .