2

I have alarms set up in my iOS Clock app, with both "Vibrate on silent" and "Vibrate on ring" switches set to ON in the Settings app. For the last several months I've been relying on a silent audio file to create a vibrate-only alarm to wake me up. But this morning, it seemed to stop working — the alarm went off, but made no sound and did not vibrate. Only the screen lit up like usual.

I've tried deleting and re-creating the alarms, un-toggling and re-toggling the vibrate switches in Settings, trying alarms using the built-in ringtones, and rebooting the device, and nothing seems to make alarms vibrate again. As well, the state of Do Not Disturb mode has no effect (though it of course never has).

Even stranger, I also have some other iPhones to test, and they're all now inexplicably showing the same behavior.

Affected OSes:

  • iOS 7.0.2

Affected phones:

  • iPhone 4S
  • iPhone 5S

I've been using this standard alarm behavior for a long time, and suddenly it's not working without having performed an iOS update.

Any suggestions?

  • How strange! A few ideas... 1) Does the phone vibrator hardware still work (eg when you receive a call)? 2) You say this happened without having performed an iOS update, but I see you mention 7.0.2, which is fairly recent. Can you confirm the iOS 7.0.2 update didn't break vibration for you, at least initially? – Ashley Oct 21 '13 at 11:27
  • 3) I think Settings > General > Reset > Reset All Settings would be worth a try: I'm hoping this would remove Clock.app's preferences. But... only do this if you are comfortable with data loss: unfortunately I don't know what else this resets (Apple's PDF iPhone manual just unhelpfully says "All your preferences and settings are reset"). – Ashley Oct 21 '13 at 11:28
  • The hardware still works; It vibrates when I get mail and calls. iOS 7.0.2 is pretty recent, but the alarm definitely worked for many days after the update. Also, I've done a Reset All Content and Settings on another iOS 7.0.2 phone (my old 4S), and its alarms are also not vibrating, making me think it's an iOS bug or quiet feature removal. Hoping someone can set up an alarm on 7.0.2 and see if it still vibrates. – Collin Allen Oct 21 '13 at 15:09
  • Thanks for the details. I can't reproduce this, I'm afraid. Here's what I did: iPhone 4S running 7.0.2. Created new alarm, with the following settings. Time: in a min or two; Repeat: Never; Label: Alarm; Sound: a custom ringtone sound I have on the phone already (this isn't silent, though); Snooze: on. In Settings > Sounds, I have Vibrate on Ring: on; Vibrate on Silent: on. In Settings > Do Not Disturb, Manual: off; Scheduled: off. Ringer switch (on the side above the volume controls) is set to silent. When the alarm went off, I heard the custom sound, and the phone vibrated. – Ashley Oct 21 '13 at 18:20
  • One possibility I can think of that could cause this issue to appear on multiple phones, independent of iOS updates: do they all use the same iCloud account? Clock.app doesn't in theory use iCloud, so this idea is ridiculous really, but it's one thing I can think of that might be common to all your phones... – Ashley Oct 21 '13 at 18:24
1

(Sorry making this an answer, I don't have enough points to comment yet)

This probably isn't your issue as you've recreated your alarms, but I can cause my phone (iPhone 4S, 7.0.3) to do only "one" vibration by creating conflicting alarms for the same time, one having the sound as "none" and the other to any random sound.

It took a bit of juggling, but I managed to have the sound alarm start first and then immediately the none alarm started and the sound and vibrations stopped.

You must log in to answer this question.

protected by Community Nov 5 '13 at 8:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .