1

I've got 2 Macs running OS 10.6.8. I've configured one to automatically drop certain files in a folder on the other Mac. I've used an Automator script to do this, it logs in using a user name [copier] created for this purpose, and then copies the files.
This used to work reasonably well. Recently however the files are copied with the wrong permissions. The copy has read&write permissions for user [copier] and 'no access' for everyone else. It should have read&write access for everyone. The folder permissions do have read&write access for everyone, so that's not it.
How can I set the permissions of files that get copied into this folder?

  • What do the permissions of the file look like before it is sent to the file server using Automator (do they look OK?) Are you using the built-in file sharing that's enabled in System Preferences -> Sharing (ore are you running Mac OS X Server)? Are you sharing files over AFP or SMB? – Eddie Kelley Oct 29 '13 at 2:32
  • The permissions on my system (the files are in the Downloads folder) are read+write for me, and No Access for everyone. I feel dumb for not checking this before, since this is where the problem starts. I'm using the built-in file sharing via AFP. – Hobbes Oct 29 '13 at 6:45
1
+50

I'd recommend checking to see what the permissions on the source files are, to confirm that they are not set restrictively (i.e., no access for others.) It's possible that these permissions are being replicated on the share by the automator script.

If you need the enclosing folder to have more restrictive permissions, you can likely keep that setup (and use Automator to change permissions on the files before they're copied.) Although I'm not sure that Automator can modify file permissions, you can definitely use it to run a shell script (chmod 644 filename.txt?) on the files before they're copied to the server.

  • We're getting there: files downloaded by Firefox have the incorrect permissions set, even if the folder they're downloaded into have the correct permissions. – Hobbes Oct 29 '13 at 18:29
  • 1
    @Hobbes It's possible that you're seeing this Firefox bug. Apparently this occurs when doing a right-click to save the file...Dragging and dropping may allow the file permissions to be set correctly. This might be fixed in FireFox 25? Which version of FireFox are you running? – Eddie Kelley Oct 29 '13 at 18:41
  • I'm using 24.0, and the installation date is roughly the time that this problem began occurring, so it's probably this bug, yes. I'll test with the v25 beta tomorrow. Drag&drop isn't really an option with the files I'm saving (.torrent). – Hobbes Oct 29 '13 at 21:11
  • I've tested with the Firefox 25 beta, and the permissions are set differently, though still not permissive enough. So I've changed my Automator script to change the permissions before moving the file. That seems to work when I run the script manually, but when I run the script as a folder action, the receiving application still complains it has insufficient privileges to open the file, even though access is set to rw for the group 'everyone'. – Hobbes Oct 30 '13 at 20:15
  • I've added another line to the script setting access for 'group' to rw, and that has done the trick. – Hobbes Oct 31 '13 at 18:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .