2

I'm running OS X 10.7.5 "Lion". Three times now, Preview.app has gotten in a state where its icon is visible in the application switcher (+Tab) but it isn't running (doesn't show up in ps ax in the Terminal) and will not start (e.g. double-clicking a PDF document).

I've tried killall Dock, killall SystemUIServer, and killall Finder and those do restart but the stuck Preview icon is still in the application switcher. I've also tried removing the saved state under Library > Containers > com.apple.Preview but that doesn't work either. The only thing that solves it is logging out and back in again.

Is there some way to get this unstuck without having to log out?

1
  • I'm seeing the exact same thing in Yosemite beta :-/
    – Fuzzy76
    Aug 12, 2014 at 15:35

1 Answer 1

2

In Terminal.app, find the process ID for Dock with the ps aux | grep Dock command and kill it with the kill -9 PID command. An example:

$ ps aux | grep Dock
username              290   0.0  0.4  2730344  34500   ??  S    Fri08PM   0:22.48 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
username             3633   0.0  0.0  2432784    612 s000  S+    8:06PM   0:00.00 grep Dock
$ kill -9 290
2
  • This is basically the same as "killall Dock", which doesn't help.
    – Fuzzy76
    Aug 13, 2014 at 17:01
  • Thanks! Works on Mac OS 10.9.4. Don't forget to use sudo, this way sudo ps aux | grep Dock, look for Dock app PID and use sudo kill -9 PID
    – sealskej
    Aug 15, 2014 at 23:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .