0

Whenever I wake up my 2012 Macbook Pro after it's been asleep for a few hours, the screen turns on, but it is unresponsive for about a minute. During this time, the mouse cursor does not move at all whenever I touch the trackpad and the computer is unresponsive to the keyboard. I also see the WiFi icon in the taskbar act as if it is searching for WiFi (the WiFi icon is gray, but each bar turns black consecutively from bottom to top repeatedly). The computer is finally responsive after a minute or so and the WiFi icon stops searching.

Is this normal behavior for a Macbook Pro when waking? If not, what could a potential issue be?

My computer is a 2012 Macbook Pro 13 in, non Retina Display.

  • 2
    This is not at all normal. You might need to set some traps (activity monitor - look at log files) and see what's happening. The first question I would ask before troubleshooting this is "Can you make this happen?" If you know how to make the wake slow, you can test things - sleep with WiFi turned off / then repeat with it on to isolate the issue. – bmike Oct 18 '13 at 17:44
4

Actually it may be coming out of hibernation.

Do you ever get a milky white screen with a progress bar? That then goes away and you can see the screen but not operate anything?

It may be coming out of hibernation.

  • Yes, that's exactly what I see. At least most of the time. – Chance Oct 18 '13 at 20:30
  • This sounds like exactly the issue I have with my 13" 2011 MBP. Sadly, the more I research the problem, the more it sounds like "normal" behavior. It just seems like the system shouldn't take multiple minutes to resume from hibernation… – dgw Sep 14 '16 at 20:26
1

It may help to examine how many wireless networks you have setup as favorites in System Preferences -> Network -> Wi-Fi -> Advanced -> Wi-Fi -> Preferred Networks...The list of networks may be evaluated whenever your machine wakes (prompting it to try to join the most preferred networks - going from the top of the list down).

If you have many wireless networks showing inside of that window, it may help to either re-order those networks (the topmost items are preferred over the networks that show lower in the list). Your machine may be attempting to connect to several networks that are not within the vicinity when your machine wakes. Cleaning this list up (or re-ordering the items) may lessen this delay.

If you aren't opposed to removing all of the preferred networks, it may help (you would be required to re-enter the password for Airport networks that you use).

  • Great idea to check. I believe I only have a couple of preferred wireless networks, but I'll double-check – Chance Oct 18 '13 at 20:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .