7

I'm not sure how this machine was setup, but I do have control over it now as a local admin.

I need to enable fast user switching, but the option is greyed out along with some others. This is after unlocking the changes padlock.

Users and Groups

Is there anything I can do to reenable these options?

  • 1
    Apple published some OS X Security Configuration Guides. I can't find one for 10.8, but the one for 10.6 has a script (on page 253) that includes the comment "Disable fast user switching", followed by sudo defaults write /Library/Preferences/.GlobalPreferences MultipleSessionEnabled -bool NO. Perhaps try that with -bool YES? Oh: also, here is a similar question with no answers. – Ashley Oct 17 '13 at 21:40
2

This isn't a real fix, but I finally found a workaround. Even when fast user switching is disabled, you can still invoke this feature from the command line by running:

"/System/Library/CoreServices/Menu Extras/User.menu/Contents/Resources/CGSession" -suspend

This leaves your session running and goes back to the login screen.

I created an alias for this in my .bashrc, good enough for now.

0

The first step is to unlock the preference pane with an administrator user and password. Your user doesn't need to be an administrator - you just need to authenticate as one or have one help out to enable fast user switching.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .