This is odd. On my iPhone 5s (iPhone6,1 on Sprint 15.1 running iOS 7.0.2), whenever I try to send an SMS that contains either 148 or 149 characters, it fails to deliver.

It took me a couple weeks to track down what was actually going on. At first, I just thought that some messages didn't send perhaps due to network problems; it seemed random and normal. An iMessage with the same content would be delivered just fine. I finally got sick of them failing all the time (I write relatively long messages), so I sat down and worked out what the issue could be. I thought that maybe my messages were failing to certain carriers, making it a problem that is out of my reach. I sent the same samples to one of my contacts for each of the four major service providers - AT&T, Verizon, Sprint, and T-Mobile (oh, and also Google Voice as a bonus). They always failed on the 148 and the 149 length messages. Here are some screenshots to illustrate what happens:

enter image description here

At least for me, it's been 100% repeatable. I tried many other lengths as well, and so far, these are the only two that do this. I thought that it could be a bug in iOS 7, so I had my contacts count out their characters and send the suspects back to me. I received them just fine from each of them. I don't know anyone else with an iPhone 5s, so I can't test to see if it's something with either the hardware, the carrier, 64-bit iOS, or the baseband firmware.

Have any of you experienced this? (I've looked everywhere on Google to no avail.)
To anyone with an iPhone 5s, could you please try this yourselves on both LTE and 3G?
Does anyone know what could be wrong?

Edit: I just tried this again just now. I'm on 3G, and it sent the messages just fine. I was always on LTE when the messages failed, though. I will try it again when I get in LTE coverage in case it has been resolved since my findings.

Edit: My iPhone connected to LTE, so I tried it again, and it failed to send the same message that successfully sent earlier today on 3G. This is bizarre! Due to this, I think it can safely be assumed that it's not an issue with 64-bit iOS 7, because otherwise, it would have failed over both 3G and LTE. This is because iOS simply sends the SMS as the same sequence of PDU data to the baseband regardless of which wireless technology it's using, and the baseband handles everything else from that point on. I have updated the title and content of this question to reflect this newfound information.

Edit: The contact in the screenshot above named Ryan has an iPhone 5 on the same carrier. He's connected to the same Sprint LTE tower as me. We tested it, and he could send 148-character messages to me, but I could not send them back. (This should be assumed, but I'd like to state that I make sure that iMessage is turned off during all of my tests.) This leads me to believe that it's not a problem with the carrier. I'm making a cautious deduction here, but I'm going to suggest that the issue lies within the baseband firmware. Can anyone else support or confirm my hypothesis? Can anyone provide some insight into why this might occur?

Edit: Just when I though that it couldn't get any more complicated, it did. I was connected to LTE, so I thought, hey, maybe the 7.0.3 iOS update fixed it. I know that it worked earlier today at my office about 40 miles away from my home, but there's no LTE at my office - only 3G. I got home from work today, and I tried to send a 148-character message, and it failed (no luck with the update). I wanted to verify that it's an LTE-only problem, so I turned off LTE in the Cellular settings. I tried sending the message, but it failed. I turned off cellular data altogether, and it still failed. For some reason, and only on my iPhone 5s, when I'm on the tower near my home, I can't send and SMS that contains 148 or 149 characters. Now geography comes into play. Wow, this is getting out of hand. I have no idea what to make of any of this, but it's truly annoying. It's only happening for me, even though there are other people in my home on Sprint, and they can send the same messages just fine. It would be one thing if it only happened every once in a while, but it's 100% consistent and reproducible near my home. I even drove 10 miles away, and it still failed. Who would I even go to for support or a resolution in this situation? Sprint? Apple? The Midi-chlorians? I'm completely lost here.

Update: I just went through my tests again, and I've confirmed that this is still occurring.

Update: I recently moved uptown, and it hasn't been occurring here. Next time I'm back near my old place, I'll test it again to see if it's just that I'm in a non-issue location or that Sprint has fixed it.

  • 3
    Wow. That's quite a find! It wouldn't hurt to at least tell Apple about it - apple.com/feedback/iphone.html. Commented Oct 17, 2013 at 19:54
  • Have tried to repeat it on an iPhone 5 on LTE (in Europe, if that matters), but there was no problem sending the message. This is weird!
    – Rvervuurt
    Commented Oct 24, 2013 at 8:04
  • This might be due to your provider. Can you insert another SIM card in you phone and try that? Mightbe use your simcard in another iPhone and try that. Commented Oct 28, 2013 at 11:15
  • btw, the upside of this is that the NSA is not reading your messages... ;) Commented Oct 28, 2013 at 11:16
  • @CousinCocaine It does seem like a provider issue. Sprint is CDMA, so no SIM cards, though. Commented Oct 28, 2013 at 17:11

4 Answers 4


It looks to me like your texts are approaching a length where the phone needs to send a concatenated SMS. Judging from your success with 3G and not on LTE I would guess at this being an operator problem with supporting concatenation on LTE in some scenarios.

EDIT: The test you ran with your friend connected to the same tower obviously puts this to some doubt.

  • I tested it again with a different contact that was on the same Sprint tower as me. The same thing happened - they could send the 148-character message to me, but I could not send them back. Commented Oct 28, 2013 at 17:13
  • Also, you'll notice that in my fourth edit to my question, I found that it doesn't matter which cellular technology I'm using, but it appears to be geographical (either the tower is the problem, or maybe it's something else, but it only happens in certain areas). Commented Oct 28, 2013 at 17:17
  • I don't know if this will be an option for you as your phone is most likely simlocked, but in case it isn't, can you try swapping the SIM and see what happens. It could also be interesting in general to see how it reacts to taking in and out the SIM. Commented Oct 29, 2013 at 13:41
  • It's actually unlocked, but the problem with CDMA phones is that the CDMA radio takes precedence over GSM, so while it could technically connect to AT&T if I had a SIM for it, it would still connect to Sprint. Good idea, though. Commented Oct 29, 2013 at 18:05

Was having some SMS message sending failures and came across this post. I have a Samsung S3 with android 4.3 with Sprint service and can confirm that messages with both a 148 and 149 characters fail consistently. 147 and 150 character messages send with no problem.

This makes sense as in the past I would edit or manually split my messages with success but never understood why that worked. Pretty annoying but at least there is a workaround by just adding or deleting a couple of characters by looking at the character counter or on failed attempts.

  • Interesting implication that is might be a purely carrier issue and. to anything to do with a specific mobile OS or hardware.
    – bmike
    Commented Jan 14, 2014 at 18:45
  • @Marvin Thanks for the information! I wonder what we could do to determine the actual problem and what we can do to resolve it. I'm sure a Sprint rep would think I was insane if I said that messages with exactly 148 or 149 characters consistently fail to send. Commented Jan 14, 2014 at 20:41

I can reproduce this problem exactly on a Sprint Galaxy Note 3. Whenever my message contains 148 or 149 characters, it fails with "code: 34" and "Network not responding".

  • 1
    Welcome to Ask Different! This does not really answer the question. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favourite and you will be notified of any new answers. If you have a different question, you can ask it by clicking Ask Question with a link to this question if it helps provide context.
    – grg
    Commented Dec 27, 2013 at 19:27
  • @LukeMorehead It's good to know that I'm not crazy and that it's not just me! It looks like this is a problem with Sprint, then. The areas that are affected and the reasons for the problem are still unknown at this point, however. Commented Dec 27, 2013 at 20:34

Try send it as a Multi Media Message which allows more than 140 and see if that works.

  • You can't force an MMS on an iPhone natively, and the limit for SMS is 160 characters. Also, your answer should be a comment. Commented Oct 22, 2013 at 21:59
  • The question is about sending SMS messages. MMS is a different message type and can not be received by most non smartphones, and is therefor not a solution to this problem. Commented Oct 28, 2013 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .