I am facing a very strange issue while using iOS 7 on iPhone 4!

I have updated my os from iOS 6 to iOS 7 and I can't hear any sound except ringtones. Please have a look at the screenshot of my music app below.

App screen shot Here you can see volume slider is disabled, that is without pointer. Any help will be appreciated.

  • Random guess, but is your phone on Silent? Also, have you tried completely powering it off and back on? – daGUY Oct 17 '13 at 13:39
  • @daGUY: No,phone is not on silent. – preetam Oct 18 '13 at 4:49
  • 1
    I'm having the same problem with iOS7 and sometimes it cuts in and out of the music... It's rather frustrating... Anyone found a solution yet? Now I've completely lost all sound through my speakers... Turned it on and off about 5 times... Closed the app and reopened... Made sure all the sound is on... Nothing's working... – user59955 Oct 21 '13 at 11:36

It sounds like it is most likely stuck in DOCK mode; it thinks something is connected to the dock, and is passing all audio through dock connector which then also abdicated volume control to the accessory rather than on the phone/pod/pad.

This could be the software stuck if it corrects itself after a reboot and a connect to USB to a computer to alert the device that it's no longer supposed to send line-out level sound.

Basically, when you connect an iOS device to a car stereo or other dock, there is some intelligence to determine if the volume should work like headphones where the user can control things or in line mode where the iOS device should send a line-level signal and the car audio is responsible for amplification and volume control.

If reboots and restores do not fix this, you will need to get the hardware cleaned and/or repaired. It could be as simple as lint in connector making the pins not connect electrically (or even physically preventing proper insertion). It also could be an internal failure (corrosion due to liquid damage or just a fault in the circuitry without an external cause). You can follow the examples given in this Q&A to troubleshoot dock connectivity issues

  • How could the OP get the phone out of Dock mode again? – nohillside Oct 19 '13 at 12:52
  • I've taken the core of this idea and fleshed it out. Hopefully everyone approves. This is the most logical explanation for no volume slider although as you can see, not enough troubleshooting has been reported by the asker of the question to determine the real reason for the failure of the volume slider to appear as expected. – bmike Oct 21 '13 at 12:46

I had the same problem. My phone was stuck in dock mode. I followed someones advice on Apple community. They solved the problem by going to a dock station with speakers and plug the iPhone in, play music and removed the iPhone from the dock. I did this and it worked for me.


If you had called me when I worked at Apple and took calls on iOS 7 (I was doing that during that release), I would go through some basic troubleshooting, but really if the only thing that changed was the upgrade, and you say it's not on silent, etc, I would be very suspicious that something went wrong during the upgrade.

It's more satisfying to say "do x y and z and that fixes it" but a lot of the time with these kind of problems you just run a restore and that will solve it. It's unlikely your hardware went bad exactly at the same time, so the upgrade is about 99% sure to be the problem.

Looks like 7.1.2 is the newest OS you can get, I recommend you make sure you have proper backups, then put the phone in DFU mode and restore it with iTunes. If you run into any problems look at this page from apple.com.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .