0

When I try to boot into OSX, after 30 seconds or so the Apple symbol is replaced by a circle with a line through it. If I try single user mode, it stops at a certain point before booting entirely and says "waiting for root device."

However, I was able to successfully boot into OSX after trying five or so times. Then, after running for a few minutes it froze up. I've been able to repeat this a couple times, but 90% of the time it just shows the circle.

I do not believe this is a hardware problem because Windows works fine (I am typing this from Windows), but it doesn't scream "software problem" because it's intermittent.

Any advice?


PS: I replaced the stock hard drive last year with this: http://www.newegg.com/Product/Product.aspx?Item=N82E16820171569

I found a blog post http://www.klein2.de/does-apple-drop-the-intel-x25-m-ssd-support-with-10-8-3/ that seems to describe my problem, but I doubt that it is for the same reason. The screenshot with the black background is exactly what I see when I try to boot into single user mode.

1

I brought it to the Apple store where they replaced the hard disk cable for free (possible thanks to Applecare). OSX works again. This solution defies logic to me; I didn't think it could possibly be a hardware problem because Windows worked fine.

I am including the relevant parts of their problem writeup below:

Issue: Mac OS partition boots to a prohibitory symbol. 
Windows partition can run fine
Occurred after waking from sleep, computer froze completely 
Steps to Reproduce: Observed at bar 
MRI passes, third party memory 
Booted to 10.8 installer and internal drive did not mount 
Booted to storage diagnostics and no hard drive detected 
Proposed Resolution: Replace hard drive bracket, has third party drive, run storage diags after bracket and see if drive is recognized 
0

I think the first thing you should do is apply the latest firmware update to your SSD. It sounds like a firmware issue to me. You can do this from Windows. You can download the Sandisk app for that here (but I suggest you don't trust an exe download from a random internet stranger! Check it first). This won't necessarily fix your issue, but at least you can illiminate that problem.

This page has some details that may help you diagnose your problem.

2
  • Thank you for your response! There does appear to be a firmware update, but the installer insisted on creating a bootable USB, which my mac was then unable to find. There was an option to create a bootable CD, but I could not find the .iso to burn. I'm still stuck, but I'm bringing it to the Apple store tomorrow to see if they know what's going on. – danmcardle Oct 17 '13 at 0:24
  • What's so strange to me is that I haven't had an issue for a year and the issue didn't crop up immediately after a software update. It was working fine last night, I hadn't rebooted in a few weeks AFAIK, and then this morning when I woke it from sleep it froze and wouldn't boot OSX anymore. – danmcardle Oct 17 '13 at 0:25
0

If you have a Mac model released in mid-2010 or later -- If your Mac has the latest firmware updates, it can access OS X Internet Recovery. If the local OS X Recovery system is missing, late-model Mac computers should automatically attempt to access OS X Internet Recovery.

You can also force a system to start up to OS X Internet Recovery by holding down Command-Option-R. This worked for me. When you do this, your Mac tries to re-download the OS X Recovery system from Apple servers. If successful, this process re-creates the local Recovery HD partition.

Reference:
https://support.apple.com/en-us/HT201314
https://support.apple.com/en-us/HT202313

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .