5

I'm using Microsoft PowerPoint 2011 on a Mac. When I use "Save As..." and choose PDF format, I would like a PDF that has all the slides except for slides marked as Hidden in my slide deck. But I always get all slides in the PDF.

This is a problem, of course, because hidden slides are hidden because they aren't ready for public viewing.

I would think there should be an option to suppress hidden slides, but I can't find one. My colleagues who use Windows do seem to have the option on MS PowerPoint for Windows.

It is possible to suppress hidden slides during Print... but then I am at the mercy of print formatting, and the PDF contains print margins that I can't suppress.

Has anyone found a solution for this?


Solution:

There appears to be no way to make "Save As PDF" skip hidden slides on the Mac version of Powerpoint.

So the workaround is to use Print instead, and print to PDF within that dialog. One can fix the margin issue this way:

  1. Open the Print dialog.
  2. Click Page Setup... to choose a paper size.
  3. Change the Width and Height to match the full width and height of the paper you choose. For example, if you select Letter size, the default width and height are 10" x 7.5", so change it to be 11" x 8.5".
  4. Now one can print to paper or print to PDF and get the full bleed, and hidden slides stay hidden.
  • 1
    You should put your solution as an answer to your question (on the bottom of this page). After a day or 2, you can mark it 'accepted'. Now, everyone with the same problem can find the solution in the 'Answer' section. – CousinCocaine Sep 13 '14 at 6:51
  • Thanks for you suggestion @CousinCocaine. There was a bounty involved, and I wanted to grant the bounty to the person who led me to the solution. – Bill Karwin Apr 26 '16 at 20:11
5
+50

Instead of Save As... PDF, Print->"Save as PDF". You can get around the print margins by setting up a printer/presentation that has no margins, "full bleed".

A few important steps:

  1. First, go to File -> Page Setup and make sure that you've got the dimensions there identical for the default paper size in the printer. In my case, it's 8.5 x 11 inches for Letter size paper. Read the dialog box carefully, and select the option that lets you set a size larger than the printer will allow.

  2. In the print dialog, make sure you do NOT have "scale to fit paper" checked.

You should now see that the print preview in the print dialog is edge to edge.

Note that the print preview of my 1 slide shows full bleed

  • Can you be more specific about the steps to do that? I have tried, and I have configured the printer margins to 0.0 inches. But there is still a margin when I print, whereas there is no margin when I save as PDF. – Bill Karwin Sep 11 '14 at 16:55
  • Updated the answer with more info. – webmarc Sep 11 '14 at 19:03
  • Thanks for the additional info, but it's still not working. I did the steps you describe, but I still get margins. I have never seen the "full bleed" option in any dialog in the UI. Perhaps my printer device (Canon MX700) is just not capable of a full bleed. – Bill Karwin Sep 11 '14 at 20:44
  • imgur finally stopped being mad at me, see pic. Does your preview look similar, or do you have the margins even in the preview? – webmarc Sep 11 '14 at 20:48
  • Aha! I found the solution. See my summary above. Thanks for your help. I'll mark this answer as accepted so you get the full bounty. – Bill Karwin Sep 11 '14 at 23:54
0

Another approach would be to move all the hidden slides to the end of the presentation, Save as PDF, and then excise the hidden slides after creating the PDF. You could always insert a slide before the hidden slides stating that "The following slides are not part of this presentation"...just in case you forget to remove them from the PDF before circulating.

  • Yes, that is another approach, but it loses information. Where did those hidden slides originally belong? Yet another approach would be to leave the hidden slides where they belong, and either print a custom subset of slides to PDF, or else use a PDF tool like Acrobat or Sejda to excise specific pages from the PDF instead of those at the end. But all of these seem like unnecessary work — PowerPoint should do that for me. – Bill Karwin Jul 19 '18 at 16:42
  • No question that this is stupidity on the part of PowerPoint. "Hidden" should mean hidden. I think the conceptual problem is that if you "Save as" another presentation format (a different PPT format for example) you probably want the hidden slides, but if you "Save as" a presentation format (PDF, video, series of graphics files) you probably don't. But for "consistency" the programmers at M/S made all "Save as" formats work the same. – David Crowe Jul 19 '18 at 21:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.