I have tried many available solutions (searched through similar questions), most of them was quite obvious - like editing Info.plist in the application package, but oryginal application Info.plist data seems to look fine (it has correct file type definitions):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <string>Created by Qt/QMake</string>

Whatever I do, I can't force OS X to show this application in "Open With" context menu after right clicking on a supported file.

I have also tried to reset settings with:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

but it didn't work.

Updating, removing and reinstalling etc didn't help either. Above is original application plist that works well on other Mac. It seems like only on my OS X it doesn't work.

Do you have any idea what else could I do to make this application available in the "Open With" context menu (the problem is QNapi related only)?

  • For what file types?
    – mmmmmm
    Oct 16, 2013 at 16:37
  • This is not a duplicate, as any of suggested solutions didn't worked (as I have written). Oct 17, 2013 at 9:19
  • Thanks for pointing this out. Can you please this more obvious in the title and the start of the question so we can reopen it?
    – nohillside
    Oct 17, 2013 at 9:40
  • I already changed the title and the text and there's already correct answer. Oct 17, 2013 at 13:55

1 Answer 1


I got QNapi to show up in the open with menu by changing




and then running /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -f /Applications/QNapi.app and quitting and reopening Finder.

(lsregister -f forces a file to be registered even if its modification date has not changed.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .