0

I have a circa 2007 MacBook Pro with fully-patched Mac OS X Tiger installed. I recently plugged an OEM USB keyboard into the laptop after leaving my Mac keyboard at home one day.

Now that I'm back on my Mac keyboard (and just the laptop's keyboard for that matter), the control/command/option keys are all switched around after every reboot and after waking up from sleep mode.

I have to go in to System Preferences > Keyboard > Modifier Keys and Press the "Reset Defaults" button to get my control/command/option keys mapped back to their normal configuration.

I don't have to change any of the drop down options, they're already correct.

I've searched in vain to find a way to clear out the offending settings the OEM keyboard must have injected into the configs. How can I fix this without reinstalling everything?

1

Based on this hint, you may be able to open System Preferences as the root user and configure the keyboard layout there (which will cause it to become the default).

1) Open System Preferences as root:

sudo open /Applications/System\ Preferences

2) Select the "International" System Preference pane

3) Click the "Keyboard" tab

4) Select the layout that you'd like to use, and quit System Preferences

1
  • Thanks for answering! I didn't get the usual stack exchange email so I didn't realize an answer was posted. Unfortunately, these steps don't work as there's No "Keyboard" tab on the International panel. There's an "input menu" and the correct "US English" choice is already checked. OS X 10.5.8 Jan 18 '14 at 0:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .