I have my Macbook Pro running Mountain Lion setup with partitions as follows:
disk0s1 (unnamed) - EFI partition
disk0s2 ("Macintosh HD") - OSX partition
disk0s3 ("Recovery HD") - OSX recovery partition
disk0s4 ("BOOTCAMP") - Windows 7 partition created through Bootcamp
disk0s5 (currently unnamed, but should be "Data") - exFAT partition to be shared between OSX and Windows.

Up until yesterday everything was working fine, but now the Data partition is no longer accessible by OSX or Windows. OSX simply won't mount the partition and Windows claims the disk needs to be formatted. I believe this is due to a corrupt partition table and could use some help in figuring out how to resolve this.

Unfortunately, I can't remember exactly how I created the various partitions. I would have thought I created the Bootcamp partition through the usual means and then shrunk the OSX partition to make room for the new partition, but the layout mentioned above seems to suggest otherwise. I may have created a large Bootcamp partition and then manually shrunk that to make room for the Data partition. Either way, I created a hybrid MBR partition using GPT fdisk.

Somewhat ironically, I think this debacle was caused by something I did while troubleshooting an external hard drive that is no longer readable (hardware failure). In the course of troubleshooting the external drive I had used fdisk and the Disk Management utility in Windows 7, but shouldn't have done anything to my main drive. I'm not sure, however, if just using these utilities attempts to "correct" and issues it deems necessary.

At first I thought that maybe the MBR table got corrupt so I recreated it using gdisk. This solved nothing. I had dumped out the table before and after using fdisk -d and the results were identical. After more thought, I realized that OSX probably wouldn't be using the MBR anyway, so now I'm stumped.

I've tried googling for some clues, but most of the results I've found are about the Windows partition no longer working and usually it's because of a corrupt MBR.

Any thoughts on the next steps to take would be greatly appreciated.

1 Answer 1


After a lot of trial and error and research I came across this post that solved my issue: https://discussions.apple.com/message/19084645#19084645

Long story short, running fsck_exfat on the Data partition (disk0s5) indicated that the main boot region needed to be updated and it provided an option to update it. Sure enough, this fixed it.

Prior to running fsck_exfat I tried the Verify Disk option on the partition in Disk Utility and it almost immediately failed saying "Invalid sector size: 0". Clicking the Repair Disk option failed and said the disk needed to be reformatted.

After running fsck_exfat and updating the main boot region Disk Utility still showed the partition as "disk0s5" rather than "Data". Clicking the Verify Disk option still gave there error saying the sector size was invalid, but the the partition name suddenly changed to "Data". Then, clicking Verify Disk again said everything was fine.

Hopefully this will help someone else out there. Or me, the next time I run into this...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .