For whatever reason, the "Open With" context menu in Finder is always listing every app four times (exactly).

Duplicate "Open With" Options in Finder.app

I've read about (and tried) rebuilding the Launch Services database to restore the context menu to its initial state, but nothing seems to work. I've also used Onyx.app to clear user and system caches, but I'm still left with four repetitions of each app under the "Open With" service. I have restarted the system a few times just to be sure it was not some temporary corruption of the list.

I'm running OS X 10.6.6 on a 2011 17" MacBook Pro with a fresh install of OS X (i.e. I didn't use Migration Assistant.app or a Time Machine backup). I did, however, sync all my preferences and other files using MobileMe like I always do, so I imagine it's feasible that a preference file somewhere is causing problems? I didn't notice whether this was happening before or after my MobileMe sync.

How can I fix this so one app shows?

  • Do you have any other drives (external) connected? Like a Time Machine, a Clone or something? Mar 21, 2011 at 17:04
  • Well, when I'm at work, I do have a Time Machine active, but when I posted this, I didn't have any other drives connected, except my synced iDisk.
    – user2702
    Mar 21, 2011 at 19:48
  • 1
    It's certainly strange, could you please quickly create another user, log in and see if the new user exhibits the same behavior? Mar 22, 2011 at 5:30
  • @Martín Marconcini Yes, I've verified that creating a brand new user account still exhibits this same behavior.
    – user2702
    Mar 22, 2011 at 7:14

5 Answers 5


Since this problem happens at System Level, I'm not sure if these steps will do any difference.

I assume that, like you've said, you've rebuilt your LaunchDatabase. Just in case:


You can try the Command Line version of the above (In a terminal):

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Additionally, Default Apps is a nice and free System Preference pane to control default apps (based upon extension, type, etc.) You can pretty much see and associate everything from there. It should at least give you a hint whether the problem is in the association or the finder is doing something funky.

When did this start happening? Did you install something? I see you have Xcode 4, did you get it from the App Store or you have a Developer Profile and got it via direct download? Was this happening before? Does this happen with every type of file or only some specific ones?

  • Yes, I did try to run that command, several times. It doesn't seem to have any effect. I also looked at Default Apps. Nothing really looked out of the ordinary. This started happening immediately after I got my MacBook Pro less than a week ago. I installed my typical foray of apps, but nothing that isn't mainstream (iWork, Photoshop, etc.). I got Xcode 4 from ADC, not the App Store. It seems to happen for every single file type.
    – user2702
    Mar 22, 2011 at 20:42
  • @Lucas this is something I have to investigate, especially because it happens on different accounts. Let me get back to you :) Mar 22, 2011 at 22:27
  • Thank you. :) Please let me know if there's anything else I can provide, perhaps even Screen Sharing/SSH access at some point if you want to poke around.
    – user2702
    Mar 23, 2011 at 4:42
  • @Lucas Yeah, let's hope someone more clever finds something ;) Mar 23, 2011 at 10:16
  • @Lucas The Screen Sharing would be more to satisfy my curiosity ;) But let's continue investigating a few more days. Mar 24, 2011 at 2:50

After running lsregister (as mentioned in https://apple.stackexchange.com/a/10615/24322), relaunch the finder. (To do this, do an Option + Right Mouse Click on the Finder icon in the dock, then select "relaunch".)

  • Thanks. I was having the same problem and your tip was the key to getting the above solution to work.
    – Peter Roe
    Aug 18, 2012 at 18:58
  • Mountain Lion you can relaunch Finder, at least I couldn't find it with ctrl+opt+click with mouse. All I did was just closing all Finder windows and click on the Finder icon to relaunch.
    – user33865
    Oct 31, 2012 at 19:00

For a quicker and easy-to-remember way, you can alias the command shown in the top answer into lscleanup like so:

# Clean up LaunchServices to remove duplicates in the “Open With” menu.
alias lscleanup="/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user && killall Finder"`

Add that to your .aliases file (or any other file that runs when you open Terminal) and you won't have to remember that convoluted command ever again.


I ran into the same problem and thought I'd be smart and run

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

under sudo.

That didn't fix things. It wasn't until I ran it under my user account privileges that the problem was solved.


This worked for me:

lsregister -kill -r -domain local -domain system -domain user
killall Finder

This is the bare minimum -- no extra commands, mouse clicking, aliases, or third-party applications. I borrowed it from the other answers, but I made it readable in less than 80 columns!

You must log in to answer this question.