6

On my OSX laptop (10.8.5) I've recently been unable to sign into iMessage. By recently I mean approximately a week. I've not done any updates that I recall lately.

Coworkers are able to send me messages and my phone gets the messages directly over iMessage, so my account is working on this network (wifi and wired go through the same set of equipment out to the internet, so it's not a port blocking issue, and we're a small network of about 50 users) and my account is working in general.

I can login to https://appleid.apple.com just fine from my computer. I'm logging into the computer and my phone with the same gmail address and password in both places.

Next steps?

One solution on the internet was "do you have a serial number in "About This Mac" and I do.

1

How to Fix Messages

The following steps worked for me:
Update December 2016 - this happened once more - this fixed it again, so I'm even more certain of it now.

  1. Clear PRAM (NVRAM)

    Hold Cmd ⌘+Opt ⌥+P+R at the chimes until they are heard for a second time, then release

  2. Start in Safe Mode

    As soon as you hear the second chimes hold Shift ⇧ & keep holding until you see the regular startup progress thermometer

  3. Attempt to login to iMessage.

    Mine at this point appeared to fail & the iMessage login screen just went grey.
    I stared at it for 5 minutes, then rebooted.

  4. Done.

Recommended but Unsuccessful

These things were recommended elsewhere but they did not work for me:

  • Checking Firewall settings til I was blue in the face.
    It worked yesterday & still works for all other machines in the house...
  • Changing DNS provider.
  • Logging out of everything iCloud related then back in again.
  • Any amount of messing with the keychain - Repairing, Erasing[1]
  • Restoring random items in ~/Library/Preferences; including, at one point, the entire folder
  • 'Repair install' using latest Combo Update.
  • Recovering entire drive from a day-old known-good clone.
  • Reinstalling entire OS from Time Machine.

I'm copying this answer to all relevant Stack Exchange questions, in case it helps others. You would not believe the amount of chasing round I did to fix this one ;-)


[1] Many articles (& Keychain Repair itself) claim that com.apple.security.plist ought to be owned by the user - in fact every time you fix that, next reboot it reverts to being owned by root.

I gave up trying to 'cure' that as it appeared to make no difference in the end.

0

Despair and desperation (not that my life was ending, but damnit, I use this a lot) led me to just experiment a bit, and I found that my keychain access wouldn't open either. So I killed my keychain and I was able to reassociate.

I really don't like that solution, but it works. C'est la vie.

0

Same problem, desperation... finally I noticed there was a preference alternative in one of the windows, which could be either Adium or Messages. The thing was set to Adium, which I had long ago trashed. I reinstalled Adium and still the problem persisted, so I changed the default preference from Adium to Messages and got it to work. On both Macs I've had to set two programs in motion, and hunt in them for replies, but at least I am now able to log on and get it to work at all. The work-around is better than nothing, and possibly a step toward a solution. --Hank

0
  1. Sign out of both iMessage and FaceTime from every device you can (including iPhone, etc.).
  2. Reboot your mac.
  3. Sign back into iMessage on your mac.
  4. Continue to sign into iMessage and FaceTime on all other devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .