1

I don't think I've used x11 since switching to Mountain Lion (and thus Xquartz). I recently tried to use it and my key repeat isn't working. When I press a key, it inserts the corresponding character once, then a second time after (very roughly) a quarter second, then never repeats again. I've tried xset r and xset r on from both my x11 terminal, and normal Terminal.app --- neither has any effect.

Any suggestions?

1

From @jaykru on SuperUser.SO (https://superuser.com/a/414513/152522):

Did some more searching and discovered in recent updates the key repeat rate for x in OS X is set at some odd value. Anyway, to whoever else may have this issue, run this in your shell:

    xset r rate <milliseconds_before_repeat> <repeats_per_second>

Or just xset r rate to reset the keyboard repeat rate to default X settings (i.e: something sane.)

  • i can't get xinitrc to not choke on xset's. – Wyatt8740 Apr 25 '15 at 20:46
  • Where should I put this setting? – Lenar Hoyt Nov 28 '15 at 12:40
  • @mcb you run it in the terminal – DilithiumMatrix Nov 28 '15 at 17:37
  • @DilithiumMatrix: Every time? Is there no way to have this set automatically? – Lenar Hoyt Nov 28 '15 at 22:16
  • @mcb That sets the default value. – DilithiumMatrix Nov 28 '15 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .