I have a dual Xeon Xserve, and a nagging issue. The Xserves have 2 small 8 LED arrays on the front, which show real-time cpu utilization (one array per CPU). Under Lion, these LED's would not become active until after you installed the Server.app. Currently under Mountain Lion, these LED's do not work at all, regardless if the Server.app is installed or not.

I figure that there has to be a way to see, or find out what in the Lion Server app is enabling these (a kext or something perhaps?), but I cannot figure it out. I tried comparing the system installed Kexts (/System/Library/Extension) before and after the server.app install, but did not find any new kexts.

Does anyone happen to know, or can provide any assistance in a way to dig down deeper on this? I know its not a show stopper, but its one of those things thats bugging me and I cant stop thinking about it.

up vote 0 down vote accepted

It is possible to re-enable the front-panel LED array on the Xserve when running 10.8. It appears that the process responsible for displaying/updating the readout on the front panel is the hwmond process. Unfortunately, hwmond is not included with OS X v.10.8. However, it is possible to use the hwmond executable from a 10.7.5 system.

The hardware that I tested with was an Early 2009 Xserve. After copying hwmond from the 10.7.5 system into /usr/sbin, I copied the com.apple.hwmond.plist launchd configuration file from /System/Library/LaunchDaemons/com.apple.hwmond.plist, and installed into /System/Library/LaunchDaemons on the 10.8.5 system. After a reboot (or a launchctl load -w /System/Library/LaunchDaemons/com.apple.hwmond.plist), the system identifiers are working normally.

  • Someone buy this man a beer! Worked PERFECTLY! Thank you so much. Out of curiosity, would you mind explaining how you figured this out? – Tony Oct 14 '13 at 23:23
  • First i diff'ed the extensions, frameworks, and private frameworks...no discrepancies (missing pieces) between those. Next I examined launch daemons, and noticed that the hwmond launchd job wasn't there in 10.8 (while it did exist on 10.7) – Eddie Kelley Oct 14 '13 at 23:28
  • Excellent. Thank you again! Hopefully this same method works with Mavericks as well. – Tony Oct 14 '13 at 23:32

protected by Community Jul 6 '15 at 22:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.