2

Why does Xcode open with this file every time I start or restart OS X 10.8.4? I close it each time, have never manually opened it, and have no .savedState folder for Xcode in ~/Library/Saved Application State/.

What else might be causing it to open?

Screenshot

  • 1
    Are you just closing the Window, or are you actually quitting Xcode (File > Quit Xcode)? In the first case, even if Xcode is launched on login, it shouldn't reopen that file. If the second case then that is the expected behavior. You should try moving the Xcode preferences file (it could be more than one) to another folder (~/Desktop would be convenient.) after quitting Xcode. – Ɱark Ƭ Oct 11 '13 at 20:49
  • Yes, I am quitting Xcode rather than just closing the window. How do I find the preferences file(s)? – Dylan Hettinger Oct 11 '13 at 20:58
  • They are in ~/Library/Preferences and contain "Xcode" in the filename. – Ɱark Ƭ Oct 11 '13 at 21:01
6

You can see everything that is supposed to open on login in System Preferences > Users & Groups > Login Items. These will open even if you uncheck "Reopen windows when logging back in." in the logout dialog box.

enter image description here

4

Open System Preferences -> Click on Users & Groups -> Choose your user and click on the Login Items tab.

Is the file (libwpg.rb) in the list?

If so, select libwpg.rb and then click the minus button to remove it from the login items.

  • strangely enough it was in there, no idea why – Dylan Hettinger Oct 12 '13 at 18:36
  • 1
    Glad I could help. Unfortunately I didn't feel comfortable attaching a screenshot of this procedure (since it lists users on my computer; something that I consider to be more sensitive information). I'm glad that Mark Thalman felt comfortable doing this, and hope that his screenshot helped you to resolve the question. – Chris Mukherjee Oct 12 '13 at 22:52
2

enter image description here you sound like you know what you are doing - so I may be way off, but... Have you checked that these two options are not ticked when you right click the xcode icon and look at Options?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .