14

I upgraded my iPhone to iOS 7. Previously, when I clicked on a link from an e-mail telling me about a group discussion in LinkedIn, it opened LinkedIn in Safari and took me right there. Now, Safari launches, but then as it processes, it then launches the LinkedIn app. The problem is, most times the discussion in LinkedIn is really just a link to a webpage. I'd rather just stay in Safari, especially since the LinkedIn app takes forever to load. I'm sure Safari does this with other apps, however, the circumstances haven't come up yet for me. I can't find it in the Safari settings or LinkedIn settings to stop this.

Updated to add: I have found that if I go back to Safari after it tries launching LinkedIn and force a page refresh, Safari will load the mobile (rather than app) version of LinkedIn as desired.

7

In iOS 9, I've had success doing a long tap on the link and selecting "Open" from the pop-up menu. That opens a link and keeps it in Safari rather than jumping into an app (recently tested with an IMDB link from Google search results).

3

I would uninstall the LinkedIn app. That would solve the issue - however you may not want to do that. LinkedIn data mines your phone, contacts and emails, I use linkedIn but do not trust the company.

  • Thank you, but that is not the route I was looking for. – Jay Marshall Wolman Oct 11 '13 at 19:00
  • @JayMarshallWolman This is the non-jailbreak solution since iOS 7 increases the ability of apps to ask for URL to be handed to them directly instead of ending in Mobile Safari. Unless Apple adds a layer for you to disable these URL handlers on a per-app basis or you have an MDM solution that lets you configure / limit open-in activity. – bmike Oct 11 '13 at 19:05
  • That's disappointing. I'd much rather have the choice. – Jay Marshall Wolman Oct 11 '13 at 19:13
3

I found this post helpful, which is simple and easy to do:

  1. Go to settings.
  2. Search "guided access" (or go to General > Accessibilty > Guided Access)
  3. Click on Guided Access
  4. Turn on Guided Access

Then just go to Safari and triple click home button to enable Guided Access and surf any website without letting Safari to launch apps.

  • 1
    Welcome to Ask Different! Links can break so it is good practice to include the steps needed to solve the problem. Link only answers may be deleted. Cheers! – bjbk Dec 10 '17 at 17:25
2

Just use the workaround you found - going back to Safari after it tries launching LinkedIn and force a page refresh so that it loads the mobile (rather than app) version of LinkedIn.

Also contact LinkedIn about the slowness you see in the app.

But if you want the choice of not uninstalling the app and trying other solutions, then there is at least one very tedious (really, really tedious) way to deal with it. I'm listing these here more as an exercise in imagination (and humor) than as practical solutions.

  1. One tedious way is to tap on the link, and the moment you're in Safari hit the stop (x), modify the initial part to m.linkedin.com/ to go to the mobile site. I'm not sure if this works well all the time. You can also do this by copying the link, pasting it in Safari and modifying it.

  2. Another tedious way is to follow this routine every time you open your mail:

    • Turn on Restrictions from Settings > General > Restrictions and set a passcode.
    • Scroll down, go to Apps and tap Don't Allow Apps. This will hide all apps you've installed, including LinkedIn.
    • Switch to or open Mobile Safari, use the links and stay within Mobile Safari.
    • When done, exit Safari.
    • Go to Settings > General > Restrictions and turn it off using the passcode you set earlier.
    • Continue using other apps.
  • mods - feel free to delete this answer if it's not appropriate for this site. – M K Oct 11 '13 at 20:05
  • I've actually opted to stick with my workaround. URL modification and the clever, tedious option both took longer than going back to Safari and refreshing. – Jay Marshall Wolman Oct 14 '13 at 18:17
  • As mentioned in the answer, they were meant as an exercise in imagination and humor, while pointing to some limitations of iOS in this particular context. :) – M K Oct 15 '13 at 4:46
  • BE CAUTIOUS - IT WILL REMOVE ALL FOLDERS WITH APPS AND RESTORE APPS IN ALPHABETICAL ORDER. I had to tediously resort over 100 apps. I wish I never found this solution. – Max Mar 4 '18 at 8:17
2

Settings > general > handoff & suggested apps > turn off suggested apps

Worked for me

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jun 7 '16 at 17:04
  • there is no menu suggested apps – Max Mar 4 '18 at 8:29
  • This worked for me. But in iOS 11 it is just "handoff" and not "handoff & suggested apps" – Arne S Aug 14 '18 at 10:27
  • This seems to be the answer. Single line or not, no explanation required, it works. – Jake Oct 29 '18 at 4:11
1

The easiest way to stop this automatic app launching in the browser is to hold down link until the action window pops up and then press "Open in New Tab"

0

This also irritates me on iOS 9 which more aggressively tries to 'convert' urls to apps. Which is especially annoying on the iPad pro as the YouTube app cannot run partial screen at all, whereas a YouTube tab in Safari can. So the app is a worse experience.

The workaround of tapping cancel to the 'open this in the YouTube app' prompt then refreshing the tab does work for me, though.

If there is a better way to handle this in iOS 9 or later leave a comment and I can edit this answer to improve it -- or suggest an edit.

0

Their are two ways to do it on the article your reading 1. Push the link to share and it links to safari. 2. At the bottom on the page on the iPhone there’s a square box with an up arrow, that loads the app.

  • Nobody gets asked, the app is popping automatically after login procedure. No links to push, no square boxes. – Max Mar 4 '18 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .