So my mac partition crashed...

I've tried to repair disk, fsck, reinstall OS - Everything on every list of I could find on Google, and nothing worked.

So I have a back-up of most of my files from the prior week, but I need some other things that were left on the hard drive.

Fortunately, when I boot up in Windows, the hard drive is fully functional and I can even drag and drop files into my windows partition. I think its worth noting that the files seem alright as I'm able to open them, and even took 1 file from windows on a FAT32 flash drive, and moved it to a mac with no problems. So I want to grab everything that I can from the Windows partition, format and re-install OS.


I have a 500GB G-Drive, I formatted it to Fat32 and started transferring files, at absurdly slow speeds through USB 2.0, onto it (from windows).

Now thats finally finished. The drive won't mount on Mac OS anymore. Any ideas?

Oh heres some system info if that helps:

On Mac

  • Mac OS Extended (Journaled)

  • Format : Mac OS Extended (Journaled)

  • Owners Enabled : Yes


  • Format : MS-DOS (FAT32)

  • Owners Enabled : No

Windows 7 Home

  • NTSF
  • 1
    I'm not sure I get what you're asking. Just copy the files from Windows that you need - no matter how absurdly slow the transfer takes, then wipe both partitions and start over. Why do you need to mount the Mac drive anymore? Perhaps if you edited out all the side information and left the one issue you need help with, we could get you over that roadblock.
    – bmike
    Oct 11, 2013 at 18:59
  • @bmike I think user1493230 has copied the data across but now that the copy is finished the disk was removed and when an attempt to remount it was made an error is occurring. Please correct me if I am wrong user14
    – Deesbek
    Oct 11, 2013 at 19:05
  • I copied everything on the G-Drive and wanted to mount it on another laptop I have just to make sure that everything was copied over and worked, before I reformatted.
    – Alex
    Oct 11, 2013 at 19:14
  • @Alex, cool I understand exactly what is going on but have no idea how to fix it or what the issue may be so can you run the command I posted in the answer, on the mac before and after you connect G-Drive via USB?
    – Deesbek
    Oct 11, 2013 at 20:52

1 Answer 1


What error do you get? "The disk you inserted was not readable by this computer", or something else?

Could you please give the output of the command below when pasted in your command window:

syslog | tail | open -ef 

Once before you insert the disk into the USB port and once after.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .