On windows I was using "s3 Backup" to backup files to amazon s3. One of the options is to compress with zlib.

As far as I can tell there is no mac version of this app. So now I need to figure out how to uncompress those files as I bring them on my mac. Anyone know a good way to uncompress files that were compressed with zlib?

The files retain the same name and extention after they had been compressed. I tried adding different extensions to the ends of the files to see if some standard compression programs would uncompress them but they did not.

I have also tried messing around command-line with the "uncompress" command. But no luck there either. Unless I can figure out a way to uncompress them I will be force to re-upload everything to amazon with compression off.

thanks in advance

  • Additionally, if you still want to use Amazon S3 on your Mac, one of the best alternatives I've found is Arq ($): haystacksoftware.com/arq The Developer is friendly and you can even ask him if there are chances of reusing your data. Apr 19, 2011 at 16:23

2 Answers 2


To help figure out what these files are compressed with, you can try using the file command from the terminal. It should give you output like this:

% file archive.zip 
archive.zip: Zip archive data, at least v2.0 to extract
% file archive.tgz 
archive.gz: gzip compressed data, from Unix, last modified: Wed Aug  3 06:21:00 2005, max compression
% file srchive.bz2
archive.bz2: bzip2 compressed data, block size = 900k

zlib compression is built in to Mac OS X.

If the files are not automatically unarchived, you can try the following to unarchive them:

Add a .zip extension and open the file. This should do the trick. If it doesn't, try the following.

Open Archive Utility (/System/Library/CoreServices) and go to File-> Expand Archive.
Navigate to your file and let it do its thing.

Let us know how this works for you.

  • certainly a good idea. When I do that the file that is outputted is is a ".cpgz" file? it also seems to be associated from an archive.. if I un-archive that I get a zip file! which then un-zips to a cpgz file. around and around in a circle.
    – user4525
    Mar 20, 2011 at 4:17
  • 1
    I think zlib is gzip ie .gz files not .zip so try this rename and/or use the Unarchiver.app
    – mmmmmm
    Mar 20, 2011 at 8:59

You must log in to answer this question.