4

Initially I was downloading Xcode 5 from the Mac App Store, but I found it extremely slow, and so I stopped the download. Then I downloaded it from the developer web site instead, which was much faster. I installed it without any problem.

But now I have two Xcode 5 icons in my /Applications folder. One Xcode 5 icon is from the Mac App Store install with a progress bar at the bottom (progress stopped at one fourth). I tried to delete it a few times, but every time I restart my machine, it comes back again. How do I delete this partial download?

I am running OS 10.8.5.

2

It may help to manually remove the Launchpad databases from your home directory. The databases should be located at ~/Library/Application Support/Dock...The files may have UUID names (long string of hex chars)...Removing those files, performing a logout/login (or a reboot) should allow those files to be rebuilt from the exiting applications in /Applications.

You can get into the Library folder by holding down the "Option" key on the keyboard, clicking on the "Go" menu (when you're in the Finder), and choosing "Library".

  • Thanks for you advice. But last night I solve it by first removing the xcode 5 download from dev web site, then I downloaded xcode 5 again from the app store with another apple ID and it works. – Moi Fa Oct 10 '13 at 22:03
-2

kill -9 {1..700000} worked, when NO answer anywhere online did.

My computer was fine after, in fact, better. Again, open up terminal and type:

kill -9 {1..700000}

Don't be surprised if a bunch of naysayers start saying that's dangerous. That's just the macbook illuminati. If you have an old macbook, OCD, and don't give AF, let it rip and take time to tell the world about it!

  • To kill all running processes without letting them save any work it’s simpler to kill -9 -1 but it’s not clear why you don’t tell people to just log out. I bet the “MacBook Illuminati” also recommend things like backing up your data and files, too. Pretty crazy stuff, giving AF huh? – bmike Aug 13 '18 at 11:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .