1

I'm using the pinyin input on an AZERTY Macbook Pro keyboard and when I try to type a number, it prints the associated symbol instead (i.e. for "1", it prints "&", for "2", "é", etc.).

I've tried in combination with the Shift key, Fn key, Cmd key but it always only print the symbol and not the number.

Any idea how to make this work?

2 Answers 2

1

Could you use the numpad keys under fn? For example fn-J is numpad 1 and fn-K is numpad 2.

Edit: You might also use a private.xml private.xml like this with KeyRemap4MacBook:

<?xml version="1.0"?>
<root>
  <item>
    <name>test</name>
    <identifier>test</identifier>
    <inputmode_only>CHINESE_SIMPLIFIED, CHINESE_TRADITIONAL</inputmode_only>
    <autogen>__KeyToKey__ KeyCode::KEY_0, VK_SHIFT, KeyCode::KEYPAD_0</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_1, VK_SHIFT, KeyCode::KEYPAD_1</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_2, VK_SHIFT, KeyCode::KEYPAD_2</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_3, VK_SHIFT, KeyCode::KEYPAD_3</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_4, VK_SHIFT, KeyCode::KEYPAD_4</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_5, VK_SHIFT, KeyCode::KEYPAD_5</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_6, VK_SHIFT, KeyCode::KEYPAD_6</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_7, VK_SHIFT, KeyCode::KEYPAD_7</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_8, VK_SHIFT, KeyCode::KEYPAD_8</autogen>
    <autogen>__KeyToKey__ KeyCode::KEY_9, VK_SHIFT, KeyCode::KEYPAD_9</autogen>
  </item>
</root>
1
  • It looks like it's not supported by my keyboard. Typing Fn+K or +J will just type the regular letter.
    – laurent
    Oct 11, 2013 at 0:22
0

Capslock plus shift seems to work for me.

4
  • It works for 1234589, but when I type 67, I get (☆_☆). I'm puzzled why Apple includes so many funky functionalities on their keyboards, yet doesn't seem to provide a simple way to type numbers.
    – laurent
    Oct 11, 2013 at 0:18
  • 67 work fine on my machine (10.7.5). Shift key alone also seems to work at the moment. Oct 11, 2013 at 13:16
  • I'm on 10.8.5 and it looks like Shift+6 is a shortcut to make smileys, so when I press 7 after that it selects the 7th smiley. Any idea how to disable the shortcut?
    – laurent
    Oct 11, 2013 at 13:28
  • What you describe doesn't happen on my 10.8.5. Oct 11, 2013 at 15:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .