1

I have an iPhone 3G. I am trying to restore it but have had trouble all day. This is what I have done so far:

  1. Run redsn0w 0.96b6
  2. Use iPhone1,2_4.2.1_8C148_Restore.ipsw as the current firmware.
  3. Run redsn0w with default settings until the iPhone enters DFU mode
  4. Everything from redsn0w's perspective runs great - the phone installs the jailbroken data, and reboots, as expected.
  5. I then open up iTunes and still get a "an iPhone was detected in recovery mode" error. My iPhone shows the frustrating image of the USB cable plugging into iTunes.

What could I be doing wrong? I'm at my wits end here.

Thanks.

2

A program called the firmware umbrella can be used to "kick a device out of recovery mode".

1

You have uninstall iTunes completely then reinstall it, then restart your computer for this to work. Then you put your device in DFU or recovery and restore and it should work.

If your baseband is 06.15 then you will get a 1015 error if your updating to 4.3.3.

0

Solved by pushing it out of Recovery mode cycle by using ReiBoot (https://www.tenorshare.com/products/reiboot.html). I am sure there are some other apps that can do this too. It's very simple to do, I just installed it, run it, plug the iPhone in computer via USB. It detects the iPhone, offers a "push out of recovery mode" button of sort. Click the button and voila!

You must log in to answer this question.