4

I refer to How to rotate screens separately, and it is not working for me. When I clicked Displays with the other two keys on the keyboard, nothing happened. So I wonder how to rotate the screen on my Macbook Air.

7

You can rotate your MacBook Air screen using the OS X system preferences. What you need to do is:

  • Launch System Preferences (first quit it if it’s already open)
  • Hold down Command Option and click on "Display"
  • Look for 'Rotation' on the right side of the Display window and take your pick

If System Preferences is already open then holding down Command+Option doesn’t seem to make the Rotatation menu appear. If you run into that, just quit out of System Prefs and relaunch it.

(found on OS X Daily and found here on AskDifferent)


EDIT:

Cave! I had serous troubles on my MacBook Pro retina. Do NOT try this method described above in Yosemite (and properbly newer systems as well)

Read this: I recently tried this trick again to rotate my screen and got stuck in a nasty situation. My screen is inverted and my 'Display' menu in System Preferences will not open, when trying to open the 'Display' preference pane it gives me the following error:

"Preferences Error Could not load Displays preference pane."

I have tried the following things to fix it, non of these work:

  • Removed ~/Library/Preferences/com.apple.systempreferences.plist and ~/LibraryApplication Support/Dock/desktoppicture.db, and rebooted.
  • Logged in as another user or as guest user.
  • repair permissions, gives the following warning:
    • User differs on on "private/var/db/displaypolicyd"; should be 0;user is 244
    • Group differs on on "private/var/db/displaypolicyd"; should be 0;user is 244
  • Installed the 'OSXUpdCombo10.10.3.pkg'
  • Re-installed 'OS X - Mavericks over my current system'
  • Manually removed the Display preference pane from /System/Library/PreferencePanes and installed the 'OSXUpdCombo10.10.3.pkg' after that.

Luckely I have an external display that does not go 'Australian' on me, but this is quite nasty. I am now preparing for a clean install of my system as I am out of further ideas.

EDIT 2: - Temp fix/hack. This will not fix the broken 'Displays' preference pane, but it will help you to leave 'Down Under' and zero out gravity. Rotate your screen using a third party app:

'Display Rotation Menu 1.2' display rotation

EDIT 3: Complete clean reinstall of the system 'fixed' the issue. I have only restored the non-admin users via TimeMachine.

Error message: Preferences Error

  • Step One helps me after I quited System Preferences. – eccstartup Oct 10 '13 at 13:27
  • Wow, thanks for this! Apple's official docs don't mention the the keys and just say "If you don’t see the pop-up menu, your computer doesn’t support this feature.": support.apple.com/kb/PH19040?locale=en_US&viewlocale=en_US – Gerry Jun 19 '15 at 5:31
  • @Gerry, please read the update in my post. You just launched me into a hack of a morning! – CousinCocaine Jun 19 '15 at 13:03
  • 4
    @CousinCocaine It's ok, I live in Australia. – Gerry Jun 22 '15 at 2:22
3

I had this problem as well, It was a terrible shock because it happened on my brother's computer after telling him about this trick. His display got stuck upside down and the error message "could not open display preferences pane" kept showing up. To fix it I reset his PRAM which seemed to do nothing, then I shut down the computer, waited a while, and booted it in safe mode. There I had access to all the display preferences and after restarting the computer the display was back to its default setting.

TL;DR 1. shut down the computer 2. wait a minute 3. Launch in Safe Mode by holding Shift after the tone. 4. Correct settings and restart computer 5. Feel the relief

  • @CousinCocaine A later answer, but I recommend you do not try to rotate the screen again. – eccstartup Sep 1 '15 at 2:16
1

I just had this same problem, the screen got stuck upside down after I rotated it and the options greyed out, then wouldn't even open again. I fixed it by connecting to a projector, and using the menus that appeared on the projected screen to fix the laptop screen.

I have my projector display as a separate 'display', side-by-side and I think that really helped.

1

You can try entering Safe Mode by holding shift during boot. Usually, Safe Mode will clear caches etc and solve your problem. In my case, by simply entering Safe Mode and then restarting fixed this bug.

0

I Found A solution. I used the mac display port adapter with a hdmi cord and plugged it in to my tv and went to airplay and clicked open display preferences and it opened. then i changed the rotation back to Standard.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .