35

I'm running into an annoying issue with OS X's automatic spelling correction where the word nala gets automatically corrected to napa.

I've tried adding nala to my custom dictionary under ~/Library/Spelling/LocalDictionary but it still reliably makes the correction anyway.

How do I configure OS X to not automatically correct a given word short of turning off automatic correction entirely which is not really desirable?

25

Yes you can do it.

  1. Go to System Preferences > Keyboard > Text.
  2. Click the + sign on the bottom left to add a new text replacement.
  3. In the Replace column, put the word you want OS X to stop autocorrecting (no spaces are allowed).
  4. In the With column, put the exact same word you put in the Replace column.

Voila. You're done.

This has worked flawlessly for me every time.

  • 2
    Great answer. Unfortunately, this does not seem to prevent Mail (and probably other OS X Apps) from oh-so-helpfully changing "--" to "—". "--" is how you indicate a comment in Ada, so when I write sample Ada code in an e-mail, I find it very frustrating. – Ben Hocking Feb 5 '15 at 16:15
  • 3
    I might get downvoted for saying so, but this is not the correct answer. This solution, though functional, is a hack. Looks like @grgarside's answer, posted 2 years later probably when the non-hack solution was available, is the correct answer now. – boulder_ruby Jan 22 '17 at 19:29
  • Unfortunately, this does not work in Sierra. – clickbait Feb 13 '17 at 2:25
  • @boulder_ruby I posted my answer 4 months before this one, not 2 years later! Adding words to LocalDictionary using the spelling dialog, or manually editing the file, would appear to be less hacky, but I suppose this answer is easier for people to follow, many of whom may be already familiar with replacements especially on iOS. – grg Apr 29 at 7:10
15

When typing the word, right-click it and choose Spelling & GrammarShow Spelling and Grammar. This will bring up a window similar to the one below. It should say that the word was not found in the spelling dictionary.

Click Learn to teach the word to the current dictionary.

                   


The file ~/Library/Spelling/LocalDictionary only contains some of your corrections. This depends on which language you have currently selected. For example, my ~/Library/Spelling/ folder contains multiple custom dictionaries depending on the language that I have currently set. As well as LocalDictionary, I have files named en and en_GB. Editing these files instead of LocalDictionary can help set custom words when they refuse to be read from LocalDictionary.

~/Library/Spelling
├── LocalDictionary
├── dynamic-counts.dat
├── dynamic-text.dat
├── en
└── en_GB 
0 directories, 5 files
3

If you hold the option key when you hit the space bar after typing the word autocorrect will not change the word.

  • This does not work for me. – Jeffrey Simon Jul 9 '15 at 4:39
  • The only thing that works for me are one of these two annoying procedures: (1) take my hand off the keyboard, move it to the mouse and position the cursor to the "X" and click; (2) backup and change the word back to the correct spelling. The program then seems to understand that it should not attempt to change the word. It simply underlines it with the squiggly red underline. – Jeffrey Simon Jul 9 '15 at 4:45
  • This does not work for me either. – jjz Feb 4 '16 at 19:46
0

Go to System PreferencesLanguage & Text.

Choose the Text tab. There you can see all of the auto-correct words - just disable\delete nala.

  • 2
    That list relates to symbol and text substitution which is a separate feature to auto-correction and so cannot be used to solve my problem – RobV Oct 7 '13 at 15:23
0

Right click on the word and choose Learn Spelling.

0

Hitting Esc seems to override the autocorrect for me. It has the same effect as hitting the X button on the suggested "correction."

It's not a permanent fix for a word you need to use consistently, but it should help avoid you adding hundreds of words to the dictionary or turning off autocorrect completely.

  • This does not work. Hitting escape closes the autocorrect recommendations bubble but when you press spacebar it replaces the word anyways. – jjz Feb 4 '16 at 19:47
-1
  1. tap two fingers on the trackpad with the cursor on the word
  2. it will pop up a dropdown list
  3. uncheck the "check spelling" and "autocorrect spelling"

    voila! your are done ...the England People will not trouble you anymore

    the other options will be a tedious one to add all the craps one by one

  • OP specifically says not this. – Tetsujin Feb 21 '16 at 14:44
-2

Go to System Preferences > Keyboard . Go to text tab. Uncheck "Correct spelling automatically".

  • The question says "short of turning off automatic correction entirely " – Mark Nov 6 '14 at 10:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .