12

I have an Mac Mini from 2011. Sometimes (I would say 80% of the time) when I wake up the monitors, after they've been sleeping, my main monitor (a Benq G2220HD 22″, connected via DVI → Mini Displayport) wakes up with just noise. Its like a grey background with black, white, red, green and blue dots all over. To solve this I have to power off the monitor, and power it on again.

I also have a second monitor plugged in, through the included DVI-HDMI adapter (doesnt make a difference if I hook up my Benq using this method.) The second monitor works fine (I can see/use it while my other one is messed up), but it will also get the same issue if it is the only monitor hooked up.

I'm running OS X 10.8.5 (this was also on Lion and all other versions I've tried), I've done a SMC reset, and I've updated the EFI to MM51.0077.B10, which is said to fix an HDCP authentication thing, but it doesnt fix my problem.

My current solution is to just never sleep the monitor, instead have a screensaver running, but I want it to sleep because it gets really hot otherwise.

This doesn't happen in Boot Camp (Windows 7). It works fine there, so it has to be something with OS X I'm thinking.

UPDATE 26-10-2013 : This still happens in 10.9 Mavericks.

  • Have you tried: different cable(s) all, including monitor power cable. Have you tried using a different kind of DVI cable? There are 3 kinds, but not all of them will work with Apple's adapter/or monitors. THere are also MiniDP->DVI cables (no adapter required.) Have you reset the PRAM. Can you try using this monitor on a different Mac 10.8.5 machine and see if it affects it? Do you have Intel HD Graphics 3000 or AMD Radeon HD 6630M? Can you try using a different monitor in place of the BenQ with the same cables (still having second monitor connected). – NOTjust -- user4304 Oct 25 '13 at 17:41
  • Ive tried all kind of things. Im using the HD 3000. I have reset PRAM. I can not try on another Mac machine (this is my only one). Since upgrading to Mavericks, this hasnt happened again though... (maybe i yinxed myself now) – qwerty1911 Oct 25 '13 at 19:27
  • there was also a supplemental update for 10.8.5 that fixed somebody else's monitor weirdness on here, so it's possible that it was included in a fix. – NOTjust -- user4304 Oct 25 '13 at 19:50
  • Okay, still happens. Just got back from putting the lasagna in the oven, and when i returned to my comptuer and pressed a key to wake it, the screen was messed up again. So this still happens in Mavericks :( – qwerty1911 Oct 26 '13 at 12:45
  • I see it aswell on my MacBook Pro 2013 on 10.9.1. Monitor1 miniDP->DVI and Monitor2 via miniDP->DP cable. Regardless which monitor is primary or if only Monitor1 is connected - waking from "amber led" results in scrambled display for 20 secs, after that it becomes OK. Also blanking display while scrambled, but wake again before "amber led", the screen becomes OK. None of this happen to Monitor2 even if using the same DVI adapter. Monitor1 only has DVI so can't test reverse cabling. – Laas Jan 7 '14 at 14:58
1

I've experienced the same issue on a friends mac. If he switches spaces (swipe with 2 fingers on magic mouse - but i suppose opening mission control via a shortcut does the same) it's back to normal (until the next sleep)

0

Neither of the 2011 Mac Mini models have displayport capability. It sounds like you may be trying to plug the DP->DVI into the thunderbolt port. That's not going to work.

With an apple thunderbolt to DVI-D adapter you should be golden.

  • One of my monitors is connected through the Thunderbolt port, yes, using a DVI->Displayport adapter (or maybe its mini-displayport, I get them confused, it works anyway). But it still doesnt matter as however I hook the displays up this problem still occurs. It doesnt happen in Windows (through bootcamp), so nothing is wrong with the hardware, it has to be something in OS X. – qwerty1911 Nov 17 '13 at 10:52
  • Ah, I see I was wrong about the thunderbolt / miniDP thing. I wonder if the reason it works right in Windows is "Sleep is disabled in Windows 7 or 8 while a Thunderbolt device is plugged in" support.apple.com/kb/HT5219#11 – Paul P Nov 18 '13 at 17:39
0

try pulling the following files to see if it makes any difference--

/library/preferences/com.apple.powermanagement.plist /library/preferences/com.apple.autowake.plist ~/library/preferences/com.apple.systemuiserver.plist

as well, you could try resetting the pmu. http://docs.info.apple.com/article.html?artnum=300574 and you could boot to the install disk and run disk repair to see if you have any directory damage which could be causing this. http://docs.info.apple.com/article.html?artnum=106214

  • Your links don't appear to be referencing the correct documentation page — they're using a depreciated 'artnum' reference. – grg Apr 8 '14 at 10:09
0

My monitor (Mac Mini 2012 10.10 connected to Samsung TV with straight HDMI) does the same thing occasionally, with the static you describe. From various behaviors, I've come to the conclusion that it must be the graphics driver failing. I've been unable to solve it completely for the past year; perhaps my info might point you in more fruitful directions.

0

It's an Apple OS problem that I also now have on a MacBook with my two Samsung monitors. Tried swopping cables and monitors. The only solution that works for me is to hit "Sleep" - then just wake the computer again. Hey presto! - both monitors work fine. Annoying but only takes a second.

0

I don't believe it is a hardware issue because everything seems to work fine on Bootcamp. The only variable now is the OS.

What happens if you unplug the adapter from the MacMini then plug it back in? Does it work?

Try using a different DP to DVI adapter. I never had good results using the genuine Apple products, but I used this to connect to a Dell 3007wfp and all the problems similar to what you described went away: Kanex iAdapt Mini DisplayPort / Thunderbolt to DVI Adapter

That may very well solve your issue. If not, Amazon has a generous return policy if the device doesn't work - I went through two before I found this one that solved the issue.

-1

Make sure all the ports don't have any dust In them and that all the cords work

-1

I have the same problem on my Mini 2012, both with HDMI, and VGA adapter, and a third party monitor. Put an Apple monitor on it, and the problem seems to go away. I believe it's something to do with the graphic card used, and it's configuration. You can't change the card, but you may be able to afford an Apple monitor?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .