1

When I select a word and use Define, I have to readd the same dictionaries that I've previously enabled. At first I thought each app had its own preferences, but it forgets every time, regardless of the app.

I noticed that changing the interface language will also decide which dictionaries are enabled by default (and thus not forgotten).

With English as the interface language I get the New Oxford English dictionary and the Apple Dictionary (what's this?). Like this, the Japanese dictionaries I want are always forgotten.

With Japanese as the interface langauge, I get the two Japanese dictionaries and the Apple Dictionary, but the New Oxford is suddenly disabled. Enabling the New Oxford will now be temporary, and I'd have to reenable it every time.

I'm running iOS 7.0.2. How can I make my settings stick?

  • I've seen various reports of this in other forums, but no fixes. It may be a bug, but try a reset of your device. – Tom Gewecke Oct 5 '13 at 17:51
  • Thanks, but I'm afraid that didn't help (tried restarting with desired dictionary enabled, and also without to add as a fresh system). Er, did you mean a complete reset? – Louis Oct 5 '13 at 18:13
  • 1
    Reset is not restart, it is also not restore. See support.apple.com/kb/HT1430 – Tom Gewecke Oct 5 '13 at 18:55
1

Even a reset doesn't work for me, but it seems like only the Notes app has permission to actually write to the dictionary settings, so you can solve this by:

  1. Open the Notes app
  2. Highlight a word and select Define
  3. Touch the cloud icon for the dictionaries you want to enable
  4. Open any other app and now those dictionaries will remain enabled
0

Performing a "reset" (as per http://support.apple.com/kb/HT1430) appears to have resolved this issue for me!

  • It still happens for me in 8, and through a couple of resets. The bright side is that I just need to tap it again, and it loads after a number of seconds. I'm guessing they just take up too much memory for my iPhone 5. – Louis Feb 21 '15 at 12:11
  • On second thought, maybe it was always like that, but loads faster in 8. – Louis Feb 21 '15 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .