0

I need to edit plist file of TextEdit (TextEdit/Contents/plist.info) for doing this, using Xcode. But TextEdit says that I've got no permission for edit enter image description here

enter image description here

I've tried to get more permission for me, so I inscribed myself in GetInfo (Pasha is me). enter image description here

But still the same problem as on the pictures above. I was searching for an answer and found this. As you can see, this answer suggests me to do what I've already done. So I hope you know the different solution for this problem.

  • Can you please add a bit more details like which plist file you are trying to edit, what the Get Info dialog for that files shows in terms of permissions and which answer to the question you linked doesn't work and why? Add as much detail as you can think of, we love details here. – nohillside Oct 5 '13 at 15:14
  • 1
    Did you give yourself write permissions to the folder the plist is in as well? – nohillside Oct 5 '13 at 15:49
1

You also need to have write permission to the directory the file is in:

sudo chown $USER /Applications/TextEdit.app/Contents/Info.plist
sudo chown $USER /Applications/TextEdit.app/Contents

After you have edited the file, change the owner of the plist and the directory back to root:

sudo chown root /Applications/TextEdit.app/Contents/Info.plist
sudo chown root /Applications/TextEdit.app/Contents

You could also run cp /Applications/TextEdit.app/Contents/Info.plist ~/Desktop/ (which changes the owner to you), edit the file on the desktop, and then run sudo cp ~/Desktop/Info.plist /Applications/TextEdit.app/Contents/Info.plist (which changes the owner back to root).

Or use another editor:

sudo nano /Applications/TextEdit.app/Contents/Info.plist
  • 2
    after I added new item to "Document Types" in "Info.plist" of TextEdit (no matter what this item contents, even empty) the application fails to open. As soon as I delete the extra string, app immediately starts working. – littlenimrod Oct 6 '13 at 14:40
  • Comments shouldn't bei used to ask questions, please create a new question describing what you are trying to do and how it fails. – nohillside Oct 6 '13 at 16:02
  • @littlenimrod Oh, I forgot about that. Since 10.8, sandboxed applications (like TextEdit, Chess, or applications downloaded from the App Store) have crashed on launch if their Info.plist has been modified. I don't know any workarounds for it, but there is a non-sandboxed version of TextEdit on Github. – Lri Oct 6 '13 at 18:57
0

After all these steps, open Terminal and run

sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .