5

Whenever I use Google Chrome to access a login page in which I have the username/password saved in the Keychain (via Safari) Chrome would pop up a dialog box that asks "Google Chrome wants to use your confidential information stored in {some domain name} in your keychain?"

There are a few problems. 1) I'd prefer Chrome to save the credentials in its own storage, instead sharing one with Safari. 2) If not, I'd rather it to not ask me about that. 3) Failing that, it should at least give me the right credentials. This is more of a problem when I have multiple logins in the same site, and it rarely gives me the one I'd want the first few time, because it doesn't try to match the path portion of the url's (only the domain portion is matched). 4) At the very least, Chrome should give me an option to say "Deny all", instead of popping up a new one after every time I click "Deny".

Note that I use Safari and Chrome for different purposes and I don't want to delete the Keychain items. How do I stop Chrome from doing this?

3

That is many questions all in one. In order to manage our search engine, we prefer to have 1 question at the time.

1) I'd prefer Chrome to save the credentials in its own storage, instead sharing one with Safari. 2) If not, I'd rather it to not ask me about that. 3) Failing that, it should at least give me the right credentials.

To prevent the pop up is done with granting the Access Control in the key-chain.

Here is a sample:

Open the relevant key chain item and click on access control.

key chain access control

Add and allow Google Chrome to use it.

  • 1
    I added Chrome to the Access Control list (this seems to be the same as clicking "Always Allow") but Chrome still doesn't auto-fill the login credentials (still blank). I have tried several sites, and have removed the "Default" folder under Application Support -> Google -> Chrome to start a fresh profile but didn't help. It does stop popping up the dialog box though. – ceiling cat Oct 6 '13 at 3:05
-1

Click on Chrome, Preferences, Show advanced settings, uncheck the box "Offer to save your web passwords".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .