1

I have a 4S at iOS 7.0.2. My wife had a 3G (yes, that old :) and today received her 5S which has been updated to iOS 7.0.2.

When I send a message to her phone number it is continuing to be sent as SMS instead of now being iMessage. But when I sent a message to her phone number via my iOS 7.0.2 iPad it is sent as an iMessage. And when I have a relative send her a message to her phone number, that also is sent as an iMessage. Finally, when my wife sends me a message to my phone number that comes over as an iMessage.

And my phone sends iMessages to other contacts. It's just my wife's phone that it won't send iMessages to.

Now, since my wife can send iMessages and can receive iMessages from my iPad and my friends that seems to pretty clearly indicate the problem is not with her phone.

I'm wondering if my phone is being confused by the fact that her number went from non-iMessage-capable to iMessage-capable? In other words, maybe my phone is caching something and isn't bothering to re-evaluate if iMessage is active for her phone number now?

Anyone ever heard of that? Any way to clear the cache?


Update (24 Jan 2014):

Sorry I took so long to get back to this question. Neither of the suggestions below helped. Eventually (like in an hour or so) it suddenly, spontaneously starting working and has been fine since. So maybe there was some timeout or cache expiration?

  • 1
    You could also try turning of, then back on, iMessage on your iPhone 4S. Also, can you message her email address (which is associated with her iMessage) and have it send as an iMessage? It is strange that it doesn't automatically detect the switch. I have had friends change from Android and my phone immediately picks up the change. – bassplayer7 Oct 5 '13 at 13:55
1

I'd try to Reset Network Settings, as detailed here: Not receiving Text Messages after upgrade to iOS 7 -- this seems to cure a wide range of ills for Messages.

1

Check that you are sending to an iMessage enabled account. For example, if she's registered just her phone number as iMessage, you may be trying to send a message to her email account.

On you wife's 4S navigate to:

Settings >> Messages >> Send & Receive

Confirm that all of the needed addresses are listed here, add more if necessary

On your 5S

Start a new text message and pay attention to which address you are sending to in the "To:" field.

Send the iMessage to one of the accounts that appears on your wife's iMessage list.

0

Have you tried turn iMessage OFF and ON again? On both devices.

I had the same problem and it always solved it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .