1

When I updated iOS7 to my iphone, it somehow changed my settings on my computer. So now, whenever I text someone off my Macbook Pro, it sends the message from my email address. How do I change that back to send iMessages from my phone number?

2

iOS Settings > Messages > Send & Receive > ...Reached at... / Start from...

OSX Messages > Preferences > Accounts > iMessage Account > ...Reached at... / Start from...

enter image description here

3
  • When I go to my preferances on my Mac, I do not have an iMessage Account. Why don't I? – Alexis Oct 1 '13 at 21:08
  • If you don't have an account, you can't possibly be sending iMessage messages from it. It should belisted in the accounts list on the left. It might be called anything (likely your iCloud or AppleID email address) but it should say iMessage under it. – stuffe Oct 1 '13 at 21:10
  • Great, feel free to accept/upvote to show future users it solved your issue – stuffe Oct 1 '13 at 21:15
0

Not sure if it's the same for everyone, but the primary issue when you reinstall is that you have to double check that you've logged into "Use your Apple ID" for iMessage on your iPhone, which pushes the phone number option to your computer to sync up.

To do this, go to Settings -> Messages -> Send and Receive and make sure you login and select "Use your Apple ID for iMessages"

Hope this helps!

-1

The solution above isn't working. The iOS7 update somehow removed my phone number form the iMessage settings on my Mac and I no longer have the option to add the phone number. I tried clicking "add email" and entered a phone number but as soon as I hit 'enter' or 'tab', the phone number is removed automatically.

this is what I see when I go into iMessage > Preferences > Accounts

2
  • This isn't really an answer to the question. Since StackExchange sites are different from discussion forums (with extensive back-and-forth) your primary recourse here would be to post a question of your own describing your problem, or to help edit and answer other questions and get enough reputation to post a comment. – beroe Oct 2 '13 at 23:57
  • I think posting this as your own question is the best way to go, then someone can troubleshoot your own problem. – beroe Oct 3 '13 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .