With my iPhone 5 with iOS 7.0.2 on Wifi or on 3G my iMessages won't send (Progress bar stuck in the middle of the screen).

Rebooting or Airplane mode won't change anything.


There seems to be a bug with iOS7 :

To make it work again here is a procedure :

  • Disable iMessages (Settings > Messages)
  • Reset Network settings (Settings > General > Reset > Reset Network settings)
  • Enable iMessages (Settings > Messages)
  • Did you get a carrier update? I got one, and chose "later", and since then I have the same issue. Trying your fix now. – stuffe Oct 1 '13 at 12:45
  • I don't remember having one. – Matthieu Riegler Oct 1 '13 at 12:47
  • I tried these steps before the carrier update and it didn't work. Now I did the carrier update and it does work. Question: why does the carrier update only show up in iTunes? When I checked Software Update in my iPhone, it didn't see the update. When I connected to my Mac, iTunes told me to install it. Odd? – AJ. Oct 12 '13 at 5:07

I had the same problem. I was typing in the subject line. Went to settings, messages and shut off the subject line! Works great now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .