I'm testing a system which requires my iPad to (appear to) come from another location. The iPad also has to use Cisco's AnyConnect VPN client. I configured a manual proxy on the iPad, but AnyConnect overrides it.

I configured all of the traffic on my Mac to use a proxy. I then enabled internet sharing and use that connection for my iPad. I am able to successfully access the internet on the iPad, however, it does not seem to go through the proxy. Any ideas as to how I might be able to force the traffic from the shared internet to go through the proxy?


  • The proxy that I'm using is an ssh tunnel
  • I've tried editing the pf.conf file, but I've had no success.
  • What have you used to send all your traffic on the mac through the proxy? Try using "sudo networksetup -getwebproxy", it has system-wide effects.
    – rapidex
    Commented Sep 24, 2014 at 11:59

1 Answer 1


I personally use OpenVPN because it comes pre-configured with everything. It even has its own VPN app which does a great job.

Or you can set up PPTP VPN on your server, which does the same thing only you can set VPN settings in the Actual Settings.app

My server is in Amsterdam, but while I am connected it doesn't actually change your location, only where your connection comes out. It also encrypts it in the process, so if you are on public wifi, nobody can snoop on your packets.


Try Creating a VPN tunnel on your mac and share the internet to your iPad.

  • I don't have the option of changing VPN applications unfortunately.
    – suss23
    Commented Oct 4, 2013 at 12:33
  • You made a tunnel on your mac.. So try create a VPN connection on your mac, and share the wifi with the iPad. That might work :)
    – code ninja
    Commented Oct 4, 2013 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .