6

Several months ago the Groupon app had an update which I selected, but it never completed the update. It always shows up on the update list and when you tap it, it shows "Updating". The progress bar never moves. I can't stop the update and can't delete the app!

I've connected it to my PC and when I pull it up in iTunes, I'm able to move it from page to page, but it never shows the X in the upper left corner for deletion. I could do a reset of the iPod and probably get rid of it, but then I would lose the music I've transferred to it.

It's on an iPod Touch 4th generation, iOS 6.1.3.

Any other suggestions?

  • I would imagine if you had the updated version of the app in iTunes and you used the unsync option to the left of the iPod screen (in iTunes) then resented the app back you should be OK. Otherwise, hard reset the device. – Danijel-James W Sep 30 '13 at 15:11
1

Have you tried deleting Groupon, or any other problematic app, directly from your device?

Hold your finger down on the app icon. When it wiggles, tap the delete button. After confirming and deleting the app, download it again from the App Store on your device.

I've had this same problem before. I'm not sure what causes the problem but this has always solved the problem for me.

I'm not sure why iTunes won't let you delete the application. Maybe this is because it first poles your device to see if it is updating. In such a case, it may prevent the deletion from occurring.

I hope this helps. If it doesn't, I'd like to know how the device responds when you try to delete the app from the hardware.

  • 2
    Also single tapping the icon as if you were trying to open is can often make it switch states between updating and paused etc which may make the above easier to do. – stuffe Sep 30 '13 at 15:34
  • @stuffe: I'm not saying tapping it. I'm saying place your finger on the app icon and hold it there until all your your app icons start to quiver. I can see that you are a moderator, so I am sure you are aware of this. Have you found that when the state of the button/update toggle's is it preventing your iOS UI from transitioning into the application move/delete state? I've never seen that behavior happen before. – RLH Sep 30 '13 at 16:01
  • I know what you mean, I was just adding further info for the OP, not correcting or contradicting your answer - wasn't worth a full answer, so I just added it to yours. – stuffe Sep 30 '13 at 18:34
  • And, to be clear. Please understand that I wasn't being sarcastic or passive-aggressive. I, too, was responding from a simplistic perspective while still being slightly baffled if this was an issue. Thanks for the additional information. I see what you were trying to do now. – RLH Sep 30 '13 at 18:56
0

Maybe this helps: I had this problem recently with an iPhone 5s and the Dropbox app. I tapped on Dropbox to pause it, then I hooked the iPhone up to iTunes, interrupted the automatic sync, downloaded all available updates and triggered a manual sync.

And Voilà! - the problem is gone.

0
  • Go to Settings -- General -- Storage And Usage
  • Select the app that you want to delete
  • Clear its data and/or delete it permanently
0

What I would do is this.

  1. Launch the app store.
  2. Tap updates
  3. Tap cancel next to the offending app
  4. Uninstall the app. I think you already did this.
  5. Try reinstalling the app and see if that works.

I've had this issue with some of the apps I update. They do update eventually.

0

If all of the options above doesn't work, try the good old method of force restart Hold down BOTH the Power button and the Home button until the device restarts.

Remember to back up your important data before trying the force restart. Although force restart only cleans up temporary files, better safe than sorry!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .