2

I am backing up to a Western Digital network drive (via Ethernet LAN), but my Time Machine won't run automatically. Whenever I run it manually from the status bar, selecting Back Up Now it fails with the following error message:

Time Machine couldn't complete the backup to "DeviceName".
The backup disk is not available.

However, if I open Time Machine Preferences, right click on the disk and select Back Up Now, the backup runs just fine.

I tried removing / adding the drive, ⌥ alt/option + ⌃ ctrl + Click on the drive and Verify Backups but I still get this error, and I don't understand why Back Up Now behaves differently depending on how it was executed?

Edit following @AllInOne comment: when I backup from the status bar, I get the following messages in the console:

10/1/13 9:23:04.857 AM com.apple.backupd[36835]: Starting manual backup
10/1/13 9:23:05.275 AM com.apple.backupd[36835]: Backup failed with error: 19

Backing up from Time Machine Preferences first mounts the disk:

10/1/13 9:34:39.473 AM com.apple.backupd[36844]: Starting manual backup
10/1/13 9:34:39.523 AM com.apple.backupd[36844]: Attempting to mount network destination URL: afp://wd_backup@DeviceName.local/WD_Backup
10/1/13 9:34:45.000 AM kernel[0]: ASP_TCP CheckReqQueueSize: increasing req queue from 32 to 128 entries. so 0xffffff804ab26b80
10/1/13 9:35:02.486 AM com.apple.backupd[36844]: Mounted network destination at mount point: /Volumes/WD_Backup using URL: afp://wd_backup@DeviceName.local/WD_Backup
10/1/13 9:35:02.000 AM kernel[0]: AFP_VFS afpfs_mount: /Volumes/WD_Backup, pid 37105
10/1/13 9:35:02.000 AM kernel[0]: AFP_VFS afpfs_mount : succeeded on volume 0xffffff8271491008 /Volumes/WD_Backup (error = 0, retval = 0)
10/1/13 9:35:45.297 AM com.apple.backupd[36844]: Disk image /Volumes/WD_Backup/lindinglab_XR_iMac.sparsebundle mounted at: /Volumes/Time Machine Backups 1 10/1/13 9:35:45.308 AM com.apple.backupd[36844]: Backing up to: /Volumes/Time Machine Backups 1/Backups.backupdb

However even if I mount the disk beforehand (for instance from the Finder, Go, Connect to server and enter its address), Back Up Now in the status bar still fails with the same message (including in the console).

  • 1
    Do you see anything interesting in Console when you initiate the failing operation? – AllInOne Sep 30 '13 at 20:12
  • 1
    This is just a guess: perhaps opening the preference pane wakes up the drive in a fashion that simply selecting "Back Up Now" does not? If you do some operation on the drive that gets it spinning and then select "Back Up Now" does it then execute reliably? – AllInOne Sep 30 '13 at 20:15
  • @AllInOne: thanks, I edited my question with some output from the console (I selected what seemed relevant, I removed some unrelated noise that was coming in as well). And no, having the disk run (mounted a few seconds before launching the backup) didn't help unfortunately... – Calimo Oct 1 '13 at 7:55
  • At this point I should also note that I can Enter Time Machine from the status bar. Only Back Up Now isn't working. – Calimo Oct 1 '13 at 14:07
  • You are not alone: apple.stackexchange.com/questions/101023/… – AllInOne Oct 1 '13 at 19:21
3

I think I may have found a workaround with the tmutil command line tool. If I say tmutil startbackup I get this The backup disk is not available error message, however if I add the destination it seems to work.

First I determined the destination of my backups:

xavier@imac-xavier:~$ tmutil destinationinfo
====================================================
Name          : WD_Backup
Kind          : Network
URL           : afp://wd_backup@DeviceName.local/WD_Backup
Mount Point   : /Volumes/WD_Backup
ID            : 11326F32-D5BA-4FE8-83FB-E9CBD8F6FF2D

I then used this ID to launch the backups with:

tmutil startbackup -d 11326F32-D5BA-4FE8-83FB-E9CBD8F6FF2D

I added it to my crontab so it runs hourly:

xavier@imac-xavier:~$ crontab -e
42 * * * * startbackup -d 11326F32-D5BA-4FE8-83FB-E9CBD8F6FF2D
  • 1
    You could also try removing and readding the backup disk from the Time Machine preference pane or using sudo tmtutil setdestination /Volumes/WD_Backup. – Lri Oct 3 '13 at 11:27
  • @LauriRanta I had done that multiple times from the preferences pane, however for some reason doing it in the command line seemed to have some effect. Now it looks like I can run my backups from the menu bar... I'll confirm if that works. – Calimo Oct 3 '13 at 16:31
  • @LauriRanta it worked indeed from the command line. Can't explain why and what was the difference with doing that from the preference pane. I disabled the job in my crontab. – Calimo Oct 10 '13 at 7:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .