2

I recently updated my iPhone to iOS 7. Now, any messages my wife sends on her iPhone (which is still on iOS 6) as well as any messages she receives are sent to me. She does not get copies of my messages, unless I specifically send them to her.

How can I prevent getting her messages?

  • You most probably can't downgrade to iOS6 any longer. I've edited your question to focus on the message duplication issue instead. – nohillside Sep 30 '13 at 4:55
  • Ok, thanks Patrix. I have now added the IPAD to my problem. Messages my wife or I send are appearing on the IPAD, as well as on my phone. Would this possibly be linked to using a common apple itunes account email ID? – mick muller Sep 30 '13 at 5:44
  • Do you share the Apple ID you use for Mail, Messages etc? – nohillside Sep 30 '13 at 5:51
  • Yes, the apple id is shared. – mick muller Sep 30 '13 at 6:11
2

You need to look in Settings > Messages > Send & Receive > You can be received by iMessage at... and also Start new conversations from.

It looks as though your Apple ID has become set to receive messages on both (all) devices. Ensure that only the phones unique phone numbers and non-shared email address for Apple ID/iCloud accounts are included on each device.

For future consideration, note that iCloud/Apple ID accounts are free, and that on each device you log into iCloud services (like mail, calendars, imessage etc) separately from the App Store, so if you share an account for the purpose of sharing downloads (and I see no other reason to do so) then you should consider using that account for App Store usage only, and each have an individual iCloud account for all other functions, that way you won't ever cross contaminate each others stuff.

0

When you setup a new iOS device it unfortunately asks for and AppleID and then uses that same AppleID to set up the iTunes Store, Messages, and iCloud. Although that may make some folks lives easier, it causes great confusion for many iOS users that use a shared AppleID for the Store, and individual AppleIDs for other services like iCloud and Messages.

Luckily, as the answer above points out, you simply need to go to the iOS settings for Messages on each iOS device you use, and make sure that only your iPhone's phone number, and your personal (unshared with your Wife) AppleID email address is listed in the "can be received by iMessage at" setting. If the AppleID you share with your wife is listed, select it and remove it from the list.

Put simply, you and your wife need one shared AppleID for logging into the Apple Store (so you can share apps and music purchased), yet you both need you own personal AppleIDs to use with other services such as the setting for iCloud and iMessages. Note also that in your iOS settings, each of those services have their own setting for which AppleID is associated with them.

My final advice is to actually get the three AppleIDs created first, then put all of your iOS devices and/or Macs on the same table and go through the iCloud settings, iMessages settings, and iTunes Store settings on all of the devices making sure that you only use your shared Apple ID for the iTunes Store.

Although this can be confusing, once you understand this association between AppleIDs and the different services on iOS and Mac OSX, it can be quite flexible. The only real difficulty comes when more that one person shares an iPad where you want to also receive iMessages (you just need to choose who's account will send/receive text in this case).

I hope this makes these settings a bit more clear.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .