1

I have had my iOS 7 update for about a week now. Today I noticed I couldn't send or recieve messages. It says "Waiting for Activation" and iMessage won't turn on! It also won't let me press my phone number under send and receive!

Why won't it activate and how can I fix it?

4
  • what activation? from whom ?
    – Ruskes
    Sep 29, 2013 at 17:00
  • 1
    Have you tried any of the solutions in this Apple KB article: iOS: Troubleshooting FaceTime and iMessage activation?
    – grg
    Sep 29, 2013 at 17:15
  • Hey....if you want help, be there and communicate with us. Did you i message work last week.
    – Ruskes
    Sep 29, 2013 at 17:20
  • can you post some screenshots of the "waiting for activation" message?
    – Kevin Chen
    Dec 9, 2013 at 17:25

3 Answers 3

2

Oh boy I have seen this case so much... In my case, I live in Peru, and most carriers and cellular plans here have a limitation to send SMS just locally, not worldwide. iMessage activation requires that the phone sends an SMS to servers on UK (I don't know why), so the limitation blocks it and the phone stays forever on the "Waiting activation" screen.

The solution (for this situations, at least) is to buy some prepaid charge for the phone number. The prepaid ammount have no restrictions and can be used to call or send SMS worldwide, so it just takes another try disabling and enabling the iMessage service and this time it will work. It does take a couple of minutes on activating it, though.

Please keep in mind that this might be a country/carrier-specific-solution, but overall, you get the idea.

2

Reset network settings on your device and rejoin your network.

0

I have an iPhone 6. Couldn't get iMessage to work or FaceTime after I'd backed up my iPhone 4s to iTunes then attempted to restore onto my new iPhone 6. Tried everything mentioned but no luck. It turned out to be as simple as a hard reset I think it's called. Hold down the lock button and the round sensor/back button together until phone switches off (may take several seconds). When it came back on both worked. So happy!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .