1

I recently updated my OS X 10.8.5 Mountain Lion from Xcode 4.6.3 to Xcode 5 using the App Store upgrade.

As I mentioned here https://stackoverflow.com/questions/19051461/does-embarcadero-rad-studio-firemonkey-work-with-xcode-5, every time I tried to start Xcode 5, it would crash before I clicked or did anything. The console log told me that a crash log was created at myusersfolder/Library/Logs/DiagnosticReports/Xcode_2013-09-27-16245...

That log said that "The bundle \U201cIDERepositoryViewer\U201d couldn\U2019t be loaded because it is damaged or missing necessary resources.\".

So, I went to Xcode, Show Package Contents, and in Contents/Plugins, I found and renamed IDERepositoryViewer, by adding an "X" to the end of its name. Now, Xcode 5 runs without problem.

I have not used the IDE Repository Viewer -- it appears to work with SVN, whereas I use git. However, in the Xcode menu, the Source Control/Checkout window opens (although I have no servers defined),

Does anybody have any idea why a fresh Xcode install, on the very first run, would have a plugin that is missing resources, causing Xcode to crash?

(My related question on SO was about app development. This question is why Apple's app, Xcode, does not run correctly for me, so it seemed more appropriate here).

The beginning of the stack trace follows:

Process:         Xcode [284]
Path:            /Applications/Xcode.app/Contents/MacOS/Xcode
Identifier:      com.apple.dt.Xcode
Version:         5.0 (3332.25)
Build Info:      IDEApplication-3332025000000000~2
App Item ID:     497799835
App External ID: 38302662
Code Type:       X86-64 (Native)
Parent Process:  launchd [142]
User ID:         501

Date/Time:       2013-09-27 16:24:54.365 -0700
OS Version:      Mac OS X 10.8.5 (12F37)
Report Version:  10

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
ProductBuildVersion: 5A1413
UNCAUGHT EXCEPTION (NSInternalInconsistencyException): Error getting value for key 'delegateClass' of extension 'Xcode.RepositoriesViewer.MenuDefinition.HelpContextualMenu' in plug-in 'com.apple.dt.IDE.IDERepositoryViewer'
UserInfo: {
    NSUnderlyingError = "Error Domain=DVTPlugInErrorDomain Code=2 \"Loading a plug-in failed.\" UserInfo=0x7ff6b1ec5430 {DVTPlugInIdentifierErrorKey=com.apple.dt.IDE.IDERepositoryViewer, DVTPlugInExecutablePathErrorKey=/Applications/Xcode.app/Contents/PlugIns/IDERepositoryViewer.ideplugin/Contents/MacOS/IDERepositoryViewer, NSLocalizedRecoverySuggestion=The plug-in or one of its prerequisite plug-ins may be missing or damaged and may need to be reinstalled., NSLocalizedDescription=Loading a plug-in failed., NSFilePath=/Applications/Xcode.app/Contents/PlugIns/IDERepositoryViewer.ideplugin, NSLocalizedFailureReason=The plug-in \U201ccom.apple.dt.IDE.IDERepositoryVie
wer\U201d at path \U201c/Applications/Xcode.app/Contents/PlugIns/IDERepositoryViewer.ideplugin\U201d could not be loaded.  The plug-in or one of its prerequisite plug-ins may be missing or damaged., NSUnderlyingError=0x7ff6b
1ec2630 \"The bundle \U201cIDERepositoryViewer\U201d couldn\U2019t be loaded because it is damaged or missing necessary resources.\"}";
}
Hints: None
Backtrace:
  0  0x00007fff82a7faee __exceptionPreprocess (in CoreFoundation)
  1  0x0000000101080c23 DVTFailureHintExceptionPreprocessor (in DVTFoundation)
  2  0x00007fff8142f3f0 objc_exception_throw (in libobjc.A.dylib)
  3  0x000000010100ebd2 -[DVTExtension valueForKey:] (in DVTFoundation)
  4  0x00007fff825e85a9 -[NSFunctionExpression expressionValueWithObject:context:] (in Foundation)
  5  0x00007fff82670578 -[NSComparisonPredicate evaluateWithObject:substitutionVariables:] (in Foundation)
  6  0x00007fff82670493 -[NSPredicate evaluateWithObject:] (in Foundation)
....(much more follows .. if more is needed, let me know)
1

Thanks for your post of the problem, it helped me to work out what the issue is. That offending plug-in is NOT part of Xcode 5 at all. Like you, I had this happen after upgrading from Xcode 4 to Xcode 5. I did a clean install of Xcode 5 on another computer and it doesn't have that plug-in.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .