6

I have a relative who is currently travelling abroad. They are not using data roaming on their iPhone, but occasionally grab some hotel of coffee shop WiFi.

I have a problem communicating with them that is essentially as follows:

  • When they message me using a data connection, I get an iMessage as I should
  • If they are still on the data connection when I reply, they will receive it
  • If they are not on a data connection, it will sent to me via SMS
  • When I reply to that SMS, I know that they have left their iPad turned on at home, and thus all messages shows as delivered because they are getting to that device first, and not to her phone, ergo I cannot text her

Is there a way I can force a message to be sent to a recipient as an SMS message if they have their phone number configured to be a receiving address on a second device that is active and therefore receiving the messages over data first?

1

The possible solution for this is turn your network off for a moment, and try sending it as an SMS, if it goes good, else hold the blue bubble for a second and tap on "Send as Text Message". I use to do this for iOS 5, I am not sure if this has updated for iOS 7 as I haven't tested till now.

2

Anyone that had an iPhone can now de-register that phone number from iMessage delivery at https://selfsolve.apple.com/deregister-imessage

In the past, you had to know to turn off iMessage before you removed the SIM from the device to accomplish the same thing, but clearly enough people needed this that it's a self-serve option now from Apple to manage your iMessage status.

Then you can choose to SMS them or iMessage them and know when the iMessage is really landing at a device that's capable of replying to it. It doesn't perfectly solve your case, but for many it will be an ideal way to get messages reliably from non-iPhone devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .