2

I am out of my home country, so data is pretty expensive (~ $20 USD/mb). However, I do have an international SMS package.

In iOS 7, if I turn Data Roaming off, I cannot send or receive SMS.

If I turn Data Roaming on and:

  • disable Cellular Data for all apps
  • disable background updates
  • disable push data

I can still see my data usage ticking up at ~100kb per minute. AT&T obviously distinguishes between SMS and data, but it seems iOS 7 does not...

Is there a way to ensure I can send and receive SMS but keep all other data usage disabled?

4

There is no reason why SMS should be tied to your data package. Turning data roaming off, indeed just turning data off (if you are not currently roaming and merely want to prove this) should still allow you to send and receive SMS messages as these are sent through the voice connection, not the data one - it's exactly how phones have always been able to send a text before anyone ever had data connections.

So the problem is almost certainly something to do with your config or usage, rather than how the SMS systems works. I would ask you to check who you are sending to and from (are you using email addresses rather than phone numbers in messages, either as recipients or your sent from address?), and whether you have Settings > Messages > Send as SMS *ON*

  • It seems like some kind of glitch or coincidence - I turned data off and stopped receiving SMS, and never received any until I restarted my phone; then they all came flooding in even though data was still off, as you said. Since then it's behaved normally as you describe. I was very surprised and confused that data seemed to affect SMS, so glad I'm wasn't crazy. Thanks! – Rex M Oct 3 '13 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .