I looked at some of the other Q&A here and didn't see a duplicate of this one (e.g., How can I figure out what's slowly eating my HD space? and other linked and related questions).

Finder reports that my 500 GB drive is using 499.248 GB.

OmniDiskSweeper reports a bit more than 358.64 GB once it seems to have settled to final values:

Users          287.2 GB
Applications    26.2
Developer       16.4
Library         10.9
private          6.2
lost+found       4.1
MSI              3.6
System           3.5
usr              0.4977
Google Earth.app 0.0461
others, less than .1    
Total          358.7438 GB

(I got this by running sudo open OmniDiskSweeper.app, which gave the same result as running it without the sudo. It is reporting on hidden files.)

I also ran GrandPerspective on the ~Users folder, and it accounted for only 266 GB, which is 21.1 GB short of what OmniDiskSweeper reports. (By the way, GrandPerspective version 1.5.1 doesn't seem to be able to scan the whole disk, only folders. I htought I used it to scan the whole disk in the past.)

So, by OmniDiskSweeper's account, I have about 140 GB unaccounted for. Are there any other tools that might tell me where the rest is, or why it is tagged as used?


I ran Disk Utility Verify and the results reported are

Verifying volume “MacbookPro3”
Checking file system
Performing live verification.
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking volume bitmap.
Checking volume information.
The volume MacbookPro3 appears to be OK.

I don't do this often, but I think I would have expected a report of something wrong, which I would then fix by running Repair. It looks like there is nothing to do here.


df -h output:

Filesystem      Size   Used  Avail Capacity  Mounted on
/dev/disk0s2   465Gi  464Gi  490Mi   100%    /
devfs          185Ki  185Ki    0Bi   100%    /dev
map -hosts       0Bi    0Bi    0Bi   100%    /net
map auto_home    0Bi    0Bi    0Bi   100%    /home

df output:

Filesystem    512-blocks      Used Available Capacity  Mounted on
/dev/disk0s2   975093952 973576656   1005296   100%    /
devfs                370       370         0   100%    /dev
map -hosts             0         0         0   100%    /net
map auto_home          0         0         0   100%    /home

I looked in /Volumes for MobileBackups. There is no folder (or volume) there by that name. But there is a folder with my disk volume name, "MacbookPro3". I tried to get it's size with Finder. Information says it's an alias, so I imagine it's a link. When I look at information for what is in it, some of the big items (Applications, Developer, Library, MSI, System, and Users) add up to about 113 GB of usage, but is that real? If it is, then this might be the problem but I'm guessing I'm looking at linked folders.

Storage under About This Mac shows all disk space, 498.73 GB, allocated to "other". Everything else is literally "Zero KB".

UPDATE 3 I restore from Time Machine to a 750 GB drive using the most current backup. Looking at utilization on the new drive showed that it was consistent with the OmniDiskSweeper report above.

I then tried restoring to a virgin 500 GB drive and received the message that there was not enough room on the 500 GB drive.

I backed up the 750 GB drive to Time Machine, then successfully restored that backup to the 500 GB drive. The utilization on the 500 GB drive is consistent with the OmniDiskSweeper report above.

So both Time Machine and the laptop OS were confused about what the actual utilization was, overstating it by 120 to 135 GB. But Time machine was able to restore without including the lost disk space. But somehow Time Machine had the lost disk space in its backup records as space used, so when it tested a new drive for adequate space, it got it wrong.

I'm not sure what happened, but it looks like I was able to get it cleared up in a very round-about way. I have reclaimed over 120 - 135 GB of drive space.

  • Did you check for bad sectors?
    – Ruskes
    Commented Sep 24, 2013 at 8:22
  • 2
    sudo open ... does not run the application as root. Try sudo /path/to/OmniDiskSweeper.app/Contents/MacOSOmniDiskSweeper instead. Commented Sep 25, 2013 at 2:46
  • Thanks, Gordon. I tried that, and it wanted to run in the terminal. It didn't seem to work. (I put the missing slash in after MacOS.) I only got this response, and then it went silent: OCCCrashCatcher: Not enabling crash catching since we're connected to a tty (and thus presumably in gdb)
    – Jim
    Commented Sep 25, 2013 at 6:37
  • Attempt the same steps in using Terminal in Recovery Mode. Does the same discrepancy exist?
    – njboot
    Commented May 4, 2015 at 0:43

2 Answers 2


I had similar issue where the used disk space shown in Finder was about 20 GB more than what the size of all files should have been.

When I tried verifying the main OS X volume (like Macintosh HD; not the drive) in Disk Utility, there was an error about an invalid free block count. I was able to get rid of the error and free up the disk space by starting up from the recovery partition and repairing the volume.

  • I tried verify, and it ends with "Verifying volume “MacbookPro3” " I will post the whole report in my question.
    – Jim
    Commented Sep 25, 2013 at 0:22

My guess is the space is hiding in plain sight - storing local copies of Time Machine data. You've documented a thorough search for problems or other hidden files - so you would expect to see this space cataloged in System Information's storage summary as Backup space.

You could also see that local snapshots could use space with the df utility:

Mac:~ me$ df
Filesystem                        512-blocks      Used Available Capacity  iused    ifree %iused  Mounted on
/dev/disk0s2                       488555536 389795920  98247616    80% 48788488 12280952   80%   /
devfs                                    420       420         0   100%      728        0  100%   /dev
map -hosts                                 0         0         0   100%        0        0  100%   /net
map auto_home                              0         0         0   100%        0        0  100%   /home
localhost:/4jkUKUTdOIvTFQroRg2f5F  488555536 488555536         0   100%        0        0  100%   /Volumes/MobileBackups

To clear out and free up all the space that MobileBackups takes:

 sudo tumtil disablelocal

That command will unmount the localhost share and free up the space allocated to hold deleted files for Time Machine review and recovery.

  • I don't think this is it. The Finder's space report omits MobileBackups, so if this were it the Finder would report the disk having lots of space. You can check for this in System Information: Choose Apple Menu > About This Mac, click More Info, then select the Storage tab, and look at the "Backups" section of the usage graph. Commented Sep 25, 2013 at 2:49
  • I agree it's a long shot - hence the "My guess…" opening. Local snapshots should self-prune and keep 10% of the drive empty no matter what. I debated commenting but figured I'd drop a little terminal here even if it's not the eventual cause or solution. Thanks for reinforcing how sketchy this guess might be with a good comment.
    – bmike
    Commented Sep 25, 2013 at 2:53
  • I'm really curious as to what is output from df. Can you add that to the original question as well? (FYI, df -h is more readable, albeit slightly less precise)
    – Kent
    Commented Sep 25, 2013 at 5:12
  • I tried these suggestions. See my second update.
    – Jim
    Commented Sep 25, 2013 at 6:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .