7

When traveling internationally and connecting to an 802.11g wireless network I'm unable to connect because non-US access points default to using channel 13 and up. From what I hear if the Mac Book Pro is purchased in Europe then it can access those channels.

Is there a way to update / tweak / etc. a US Mac Book Pro to access wireless channels 13 and up?

3

There's a rather easy solution. Right click your clock, select "Open date & time preferences". Click "Time Zone" and select "Tokyo - Japan". Then either reboot or go to sleep mode. After you power up you should see all of the channels.

Update (digging deeper):

The reason this happens is that the mac reads all wifi signals and takes country code from the strongest one, setting it as global. If it's transmitting a country code which has a blocked 13/14 channel, these channels will be blocked globally.

So what you could do is check the country code on your wifi router and bring your laptop as close to it as possible.

To see which country code is transmitted by the nearby routers and blocked / unblocked channels, go to the "About this mac -> System report -> Network -> Wi-Fi". There should be a list of channels enabled for the current session under the "Interfaces -> en1 -> Supported Channels". There should also be a list of networks under the "Current Network Information".

Check if there's any network with the wrong country code and should you know its owner, ask him to set the proper one. If your router does transmit a proper country code, just bring your laptop as close to it as possible and reboot / got to sleep and wake up. This should refresh the list of available channels for the session.

  • 1
    Very helpful answer - I could see that supported channels only included 1-11 in 2.4 GHz, which turned out to be because an access point was sending the wrong country code (US) as you mentioned. To see more, you can run /System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport -s and look at the CC (country code) column. – RichVel Nov 4 '15 at 15:59
2

After research on Internet, the problem has always been. And the only one solution I've found is to change your AirPort Card to an European model. For this you can ask to an Apple Store, or if you find the European AirPort Card for your MacBook Pro model you can change it by yourself. You can find good guides for change the AirPort Card on iFixit.

https://www.ifixit.com/Device/MacBook_Pro

Other discutions on this subject. No software solution : MacBookAir 11" - WiFi not connecting in Europe https://discussions.apple.com/thread/991213?tstart=0 https://discussions.apple.com/message/3646947#3646947

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .