4

How do I make NFS automounted volumes visible in Finder or, in other words, have opposite effect to default option nobrowse?

From mount manpage

nobrowse
     This option indicates that the mount point should not be visible via the GUI
     (i.e., appear on the Desktop as a separate volume).

This is edited mount command output from Mac Pro

mac-pro:~ shpokas$ mount
/dev/disk0s2 on / (hfs, local, journaled)
devfs on /dev (devfs, local, nobrowse)
map -hosts on /net (autofs, nosuid, automounted, nobrowse)
map auto_home on /home (autofs, automounted, nobrowse)
map autofs_nfs on /Volumes/nfs (autofs, automounted, nobrowse)
/dev/disk1s2 on /Volumes/VFS HDD 0122 (hfs, local, nodev, nosuid, journaled, noowners)
varaklani:/faili on /Volumes/nfs/faili (nfs, nodev, nosuid, automounted, **nobrowse**)
  • I would have assumed that they would just show up as soon as they mounted... – Bobson Sep 23 '13 at 21:45
1

Have you tried Finder:Preferences:General:Show these items on the desktop and check Connected servers?

That normally works for me.

| improve this answer | |
0

If you edit /etc/autofs.conf and uncomment / add the line / set to FALSE

AUTOMOUNTD_NOBROWSE=FALSE

Then theoretically automount should mount the volume and set it to be visible in Finder... however I believe there is a bug in macOS which currently means this file is not read / the setting is ignored :(

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .