I upgraded my iPhone 4 to iOS 7 last night but now I can't download apps using the App Store on my iPhone. It's still possible to get the apps using iTunes on my computer and syncing my phone, but this is cumbersome.

I get errors as shown below:

Unable to Purchase
[app name] could not be purchased at this time. Please try again later.

Is this a known issue, and how can I rectify it?

  • This really is a customer support issue. All the new answers won't be relevant and many, many things can cause this. If you have a similar question, be sure to review the help center on how to document your troubleshooting instead of just stating that X doesn't work. – bmike Jun 24 '15 at 18:20

I would suggest trying the following options:

  1. Press and hold the power button and the home button until the Apple logo appears. Once it restarts, try downloading.
  2. Reset your router from which you are accessing your Wi-Fi.
  3. If the issue persists, trying downloading apps from a different Wi-Fi network or cellular data.
  4. If these fail, Reset Network Settings (Settings > General > Reset) and do steps 2 and 3.
  5. If the issue still persists, Reset All Settings (Settings > General > Reset) and try again.
  6. As a last resort, take your phone to an Apple Store.
| improve this answer | |
  • 1
    Unfortunately none of those options managed to resolve the issue for me (although I guess they may still help the original asker). I'm fairly certain it's not related to the internet connection, as I've tried connected to a number of WiFi networks as well as my mobile network, all of which have known to work previously. – Edd Nov 5 '13 at 17:59
  • Nothing i could find to make it work I'm being angry everyday :@:@:@:@:@: – Burhan Ibrahimi Jan 3 '14 at 19:59
  • Restarting my iPad worked for me. When installing an app, it would not prompt me for my apple account password and would just keep cycling. After following step 1 above, when installing an app, the prompt for the password came up and once entered, continued on it's merry way. – erroric Sep 5 '14 at 15:41
  • Thanks The problem it was fixed by the developer of the app – user91957 Sep 24 '14 at 21:07
  • FWIW, suggestion 1 helped me when from one point on all downloads were "Waiting". This on a new iPhone 6 with iOS 8.0.2 – Thimo Jansen Oct 1 '14 at 10:12

Unfortunately, this is a somewhat common problem and there is no easy solution that is guaranteed to work (other than trying again later or downloading through iTunes on a computer and syncing).

One possibility is that this error indicates Apple's app store not being able to service your request. In that case, it does not have anything to do with the model of the iPhone or the version of iOS it's running (although you're seeing this after the upgrade to iOS 7, this error is seen in previous versions too).

Another possibility is that you have some pending app downloads (that you may have paused) and the App Store app's download information database is corrupted. In this case you could try deleting the (possibly corrupt) download information database on the iPhone to have the App Store app rebuild its database (to be safe, make sure you have a backup of your phone in iTunes before you attempt this).

| improve this answer | |

This error message most often means that your connection has been interrupted partway through a download, and less often but fairly frequently means that there is an issue with your transaction when trying to download the application.

Update: for your specific case, this might be the source problem.

Common root causes:

  • poor internet connectivity. try switching internet connection, restarting your iphone, restarting wireless routers between you and the internet, or simply waiting until a less busy time (try downloading large apps at night, if you're on a perpetually slow connection). There's a very slight chance that this might be hardware damage to your phone's antenna and/or wireless connection chips, which would be best diagnosed at an Apple store.
  • corrupt credit card or other account information in the iTunes store. Log in to your account with itunes, and review all of your information (has your billing address changed for your credit card?)
  • space issues on your iphone. There might not be enough space on your phone to download the application. There are specific error message for this kind of problem, but they are sometimes masked and show up as above.
  • Undefined or unstable software configuration. Download status, or other, store or net connectivity related information may be in a corrupt state on your iphone. The least thought intensive solution is to back up your phone, wipe all data, reinstall the OS on the phone and then restore the data from backup. There are much simpler solutions if you can identify specificaly that it's data corruption, and the potential causes for the data corruption. Please note that some states of data corruption (such as might happen if you've been messing with unlocking the phone) might not be fixable like this - you might have to remember what you did, and undo it manually.
  • Hardware, connectivity or other problems on the iTunes store server side This doesn't happen frequently, but when it does, can leave you disconnected from the store for a day or two, sometimes longer. (imagine, for example, if the store is experiencing a DDoS from somewhere on your network). Wait a week, then try again. Occasionally (very rarely), it's be worth rebooting the iphone after you've waited, and before trying again

If you've tried the easier solutions to the most common problems, and they haven't worked out, go to the Apple store and have a technician look at your phone. They usually have tools that will help quickly diagnose the more common, but harder to discover, problems, and won't usually charge you anything other than your time waiting, for finding the problem.

| improve this answer | |

I was missing the download icons for some apps. I went into restrictions and changed the app ratings to allow all ages content. Then the download icon apppeared.

| improve this answer | |
  • Could you please add steps from "Settings" to what you've done please? – Rob Mar 23 '14 at 18:24

To deal with this go to settings then go to restrictions and see the row of installing apps. Switch it on and off several times, then close settings and go to App Store. Now u should be able to download or update apps normally. Hope it works for u.

| improve this answer | |

I had the same problem as you for some reason I couldn't download any apps. And then I decided to reset my router. Turns out it was just a problem with the router after all. If you have cisco I recommend downloading linksys connect, it really helps!

| improve this answer | |

My solution was to reboot at first, then boot & go to the Restrictions page, and there I switched "Require password" option from "15 min" to "Immediately". All my frozen downloads began to ask for password, one by one.

| improve this answer | |

just goto settings and switch off the wifi and switch it on. I used 3G network i did that switch off and on, the problem reolved.

| improve this answer | |

I found the solution.

When you are in the App Store, switch your tab to Updates at bottom-right and select Purchased and try it from there.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged .